Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
54 user(s) are online (46 user(s) are browsing Forums)

Members: 0
Guests: 54

more...
Support us!
Recent OS4 Files
OS4Depot.net



« 1 (2) 3 »


Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2008/3/5 16:34
From france (bretagne)
Posts: 169
@Varthall,

First of all, I have a problem selecting Samples and Instruments (can't go to parent drives). I wish you could do an important thing which does not exist on the older version of Milky tracker.. i mean the possibility to go on all logic drives of your system (with older version, I was able to go on the partition where Milky was installed but not the others at all.... and with your new port, I 'm not able to surf on any drives and I can't go up to parent drawer).

thanks

_________________
Sam460ex
Os4.1 Final Edition
2GB Fast Memory
HD R9 TRIX 280X 3GO
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2008/3/5 16:34
From france (bretagne)
Posts: 169
@Varthall,

Are you Ok with what I explained ?

_________________
Sam460ex
Os4.1 Final Edition
2GB Fast Memory
HD R9 TRIX 280X 3GO
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2007/3/19 13:44
From Up Rough
Posts: 167
@pseudaxos

Yes, that's what I'm working on now.

   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2008/3/5 16:34
From france (bretagne)
Posts: 169
@Vathall,
Any news about Milky ?
Thanks

_________________
Sam460ex
Os4.1 Final Edition
2GB Fast Memory
HD R9 TRIX 280X 3GO
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2013/10/1 4:30
From Austin, TX
Posts: 8
@Varthall

I also would like to see a usable Milky Tracker again.

I used Milky Tracker in the past thanks to your port of some years ago. I showed the work to our Amiga Users' group.

I reached for hd-rec because of an outstanding, piano demo. But troubles with it (before becoming open source) and missing the absolutely necessary plug in for piano finally left me sour.

Milkly Tracker is cross platform and has you and possibly kask1e as knowlegable support. I find Milky Tracker very tedious to get anything other than a "march" down. The learning curve when it comes to short cuts is about the same for all other such programs.

All to say, I am willing to take Milky Tracker back rather than have nothing. So efforts you make on the program will certainly serve more than just one user.

Want a bounty for the work?

ggw

   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2008/3/5 16:34
From france (bretagne)
Posts: 169
@ggw,
Very good Idea, I'll donate

_________________
Sam460ex
Os4.1 Final Edition
2GB Fast Memory
HD R9 TRIX 280X 3GO
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2008/3/5 16:34
From france (bretagne)
Posts: 169
@everyone,

Is Varthall already in the place ??
I have no news about him since July ...

Thanks.

_________________
Sam460ex
Os4.1 Final Edition
2GB Fast Memory
HD R9 TRIX 280X 3GO
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2007/3/19 13:44
From Up Rough
Posts: 167
Hi,

I'm alive, but I have barely any free time to use my AmigaOne at home (I have two small children). I will try again to work on it these days, but I believe that someone other might be better suited for this work. And no, thanks for the bounty idea, but it's time that I'm missing, not motivation :)

_________________
AmigaOne XE - AmigaOS 4.1 - Freescale 7457 1GHz - 1GB ram
MPlayer for OS4: https://sourceforge.net/projects/mplayer-amigaos/
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2008/3/5 16:34
From france (bretagne)
Posts: 169
Hey Nice to see you again Varthall. Great to look after your children... I understand very well ! I think only you is interested in working on Milky.. noone answer this post ... Only you and I need your help to continue with this wonderful software.. DigiBooster is not useable for me at the moment.. Lack to mutch things I have into Milky...
I'll wait for a new beta from you Varthal
See you !

_________________
Sam460ex
Os4.1 Final Edition
2GB Fast Memory
HD R9 TRIX 280X 3GO
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2013/10/1 4:30
From Austin, TX
Posts: 8
@Varthall

Do you have any objection to making the work & notes you last did on Milky Tracker available?

I am a software programmer by profession. Theoretically, I can do the work. I am not versed in the available amiga library routines to help with any of the complaints. I do not care to be often reminded of bugs crying out to be repaired by someone (me) who has taken an interest.

From scratch I successfully ported a low-ish level, non trivial, c program from Solaris to Amiga 4.1.2 (I think it was), but I was very familiar with the Solaris version and no GUI was involved.

I naively thought I would be of service in porting tcl to AmigaOS4.1 so we could run the QA tests for sqlite 3.0. There, I found that low level tcl was not very straight forwardly ported. There were some technics that I had not enough understanding of Amiga OS System operation. I spent soooo many hours with so little to show.

But, if this is the only reasonable way to move programs of user interest, I am willing to consider it, but I don't want it to be THE only thing I do on my X1000.

George Wyche

   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2007/3/19 13:44
From Up Rough
Posts: 167
@ggw

Thanks for your offer! I'll maker again a try, if I won't succeed I'll gladly pass the port to you, I'll let you know. Pity about your effort on tcl, I personally wouldn't even dare to port such a beast :)

Varthall

   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2008/3/5 16:34
From france (bretagne)
Posts: 169
@ggw and Varthall,

Any news ?

_________________
Sam460ex
Os4.1 Final Edition
2GB Fast Memory
HD R9 TRIX 280X 3GO
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2008/3/5 16:34
From france (bretagne)
Posts: 169
ggw has disappear ???

_________________
Sam460ex
Os4.1 Final Edition
2GB Fast Memory
HD R9 TRIX 280X 3GO
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2011/6/3 12:49
Posts: 185
@Varthall

Please make available Milky-Tracker sources (especially Amiga changes & makefile) if you dont have time to code it anymore

Thanks Thanks Thanks

Alain Thellier

   Report Go to top

Re: Bug in Milky-Tracker :-(
Not too shy to talk
Joined:
2007/7/14 20:30
From Lothric
Posts: 269
Seems that Milkytracker compiles quite easily with CMake and SDL2 :) Could somebody summarize the Amiga issues? File requester with volumes?

   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2007/3/19 13:44
From Up Rough
Posts: 167
@Capehill

From memory, some code should be added so that other devices could be accessed apart from the one where Milky is started. Should be trivial, but I have never managed to finish the work due to time constraints. Milky used to compile out of the box as you have noticed, but a few tweaks are required, e.g. there was one define that needed to be set so that all the keys would be recognised, it has to be checked if that define is still required though. Also, at least on my A1XE speed was an issue, it used 100% of my CPU everytime a bigger module (=> 8 tracks) was played, it should be checked how's the CPU usage now.

Varthall

   Report Go to top

Re: Bug in Milky-Tracker :-(
Not too shy to talk
Joined:
2007/7/14 20:30
From Lothric
Posts: 269
@Varthall

Would you remember what key didn't work? I have now added ASL file requester for Milky.

CPU usage seems to vary between 60-80% on Sam440. I think most of it is because of drawing, playback shouldn't be that heavy. Should be profiled anyway.

If I open another module while playing the old one, CPU stays at 100% for a moment and then drops down. If I stop playing before loading then it works ok.

   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2007/3/19 13:44
From Up Rough
Posts: 167
In the old Milky compiles you could easily detect what keys were not working by selecting an instrument and pressing all the keys from Q to P, one by one; some of them would not play the note. I have checked in an old revision of the source code, there was a commented out "#define NOT_PC_KB" in src/tracker/sdl/SDL_KeyTranslation.h which needed to be set so that all the keys would work. I see that it has since been removed; if all the keys work as expected (i.e. the Q-P and Z-M rows mimic the white keys on a piano, the 1-0 and A-L the black ones), then no fix is required anymore.

Great to hear that the ASL requester is now working. BTW there are a few #ifdef AMIGA in compression/unlzx.cpp and an #ifdef __AMIGA__ in ppui/osinterface/posix/PPSystem_POSIX.cpp, I wonder if both are already defined in the SDK, alongside __amigaos4__.

Varthall

_________________
AmigaOne XE - AmigaOS 4.1 - Freescale 7457 1GHz - 1GB ram
MPlayer for OS4: https://sourceforge.net/projects/mplayer-amigaos/
   Report Go to top

Re: Bug in Milky-Tracker :-(
Not too shy to talk
Joined:
2007/7/14 20:30
From Lothric
Posts: 269
@Varthall

I checked the keys and they seemed to work for me. What is the story with various preprocessor symbols? Did you also port MT for OS3.x?

I have made the current version available on my home page at http://capehill.kapsi.fi/ . Please test!

   Report Go to top

Re: Bug in Milky-Tracker :-(
Quite a regular
Joined:
2006/11/29 8:09
From Lyon, France
Posts: 906
@Capehill

Thanlk a lot! I've informed Pseudaxos who has created lot of modules with MilyTracker on AmigaOS 4.1 and was eagerly waiting for this new fixed version.

_________________
--
AmigaONE X1000 1,8Ghz, 2GB, Sapphire Radeon HD 7700, with Amiga OS 4.1 FE
http://www.amiga-ng.org
   Report Go to top


« 1 (2) 3 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project