Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
75 user(s) are online (62 user(s) are browsing Forums)

Members: 0
Guests: 75

more...
Support us!
Recent OS4 Files
OS4Depot.net



(1) 2 3 »


Bug in Milky-Tracker :-(
Just popping in
Joined:
2008/3/5 16:34
From france (bretagne)
Posts: 168
Hello,

I use Milky Tracker for quite a long time now and I want to report you one bug (I have sent a mail to the autor but I get no answer for the moment..).
When you've got 8 voices and you want to mark all channels to copy/paste them to another pattern... then Milky crashes
Who could resolve it ?

Thanks

_________________
Sam460ex
Os4.1 Final Edition
2GB Fast Memory
HD R9 TRIX 280X 3GO
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2007/3/19 13:44
From Up Rough
Posts: 167
@pseudaxos

Hi,

I'm the author of the Milkytracker port. I'm sorry you didn't receive any response from me, the email address mentioned in the Milkytracker docs and on OS4Depot is no longer valid (hotpop.com has shut down a couple of years ago). I have never encountered the bug you mentioned, I'll try to reproduce it at home. Anyway, the bug could be common for all the ports and not specific for the OS4 one, the best thing would be to port the latest Milkytracker version (v0.90.86, released last month) before investigating further. I'm very busy lately, I'll see what can I do these days, can't promise anything though.

Varthall

   Report Go to top

Re: Bug in Milky-Tracker :-(
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 4192
@Varthall

Is it pure recompile, or some additional os4 code in ?

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2007/3/19 13:44
From Up Rough
Posts: 167
@kas1e

Some fixes are required for the file opening requester (handling the HOME environment for example), what has to be added too is the support for a list of all the current devices (ATM Milkytracker on OS4 can load/save data only its current partition). There was also a nasty bug which prevented the compile of one of the audio replay modes due to a bug in the version of GCC included in the SDK, a workaround was required, I don't know if it was submitted in the Milky's CVS (they are now using GitHub I see).

EDIT: it requires autoconf too to generate the makefile (at least the old v0.90.80). I compiled it by generating the makefile on Linux and adapting it to run on OS4.

Varthall

   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2008/3/5 16:34
From france (bretagne)
Posts: 168
@Varthall
Ah ok.. Thanks for what you could do (perhaps).
And thanks for your great port of milky on Os4

_________________
Sam460ex
Os4.1 Final Edition
2GB Fast Memory
HD R9 TRIX 280X 3GO
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just can't stay away
Joined:
2006/11/26 16:47
Posts: 1420
it's hosted on github now and they accept patches, so i guess some amigaos4 changes could be submitted.

   Report Go to top

Re: Bug in Milky-Tracker :-(
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 4192
@Varthall
In other words nothing hardcore, just home, handling of filesystem normaly as well as deal witch compiling itself. Should be pretty easy, will try soon latest one

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2007/3/19 13:44
From Up Rough
Posts: 167
@kas1e

Ok, just wanted to let you know that I'm compiling it right now too :)

Varthall

   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2008/3/5 16:34
From france (bretagne)
Posts: 168
@Varthall, @Kas1e @spotUP

Very very great !
Milky makes me happy and big basses too

_________________
Sam460ex
Os4.1 Final Edition
2GB Fast Memory
HD R9 TRIX 280X 3GO
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2007/3/19 13:44
From Up Rough
Posts: 167
A first version, straight compile with no changes added:

https://docs.google.com/file/d/0B2qDqD ... 01rNmVjYWlUUW8/edit?pli=1

I'm working now on the file handling, as for now modules can be loaded only from the same folder where Milky is stored. I have tried to load an 8 channel module, selected "Mark all" to select all the tracks and copied them, no crash observed.

Varthall

_________________
AmigaOne XE - AmigaOS 4.1 - Freescale 7457 1GHz - 1GB ram
MPlayer for OS4: https://sourceforge.net/projects/mplayer-amigaos/
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2008/3/5 16:34
From france (bretagne)
Posts: 168
Great work !
No crash with this beta here too. That's very important to not waste time during the music edition

_________________
Sam460ex
Os4.1 Final Edition
2GB Fast Memory
HD R9 TRIX 280X 3GO
   Report Go to top

Re: Bug in Milky-Tracker :-(
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 4192
@Varthall
If you will have no time to commit aos4 patches to main milky's repo, plz share them so i can do that boring work for you. Having them in main repo will be good for anyone later for pure compile/run

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just can't stay away
Joined:
2006/11/26 16:47
Posts: 1420
varti, nice!

   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2008/3/5 16:34
From france (bretagne)
Posts: 168
@Varthall,

Just to say that I tested a little more the Milky Beta version and I can't use it.. Lots of problems when for exemple I load samples (I must do octave down and down to get the real speed of all samples, problems when I press keys of my keyboard to listen samples etc etc... )
So, is there any updates you will upload next on os4depot ?

Thanks

_________________
Sam460ex
Os4.1 Final Edition
2GB Fast Memory
HD R9 TRIX 280X 3GO
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2008/3/5 16:34
From france (bretagne)
Posts: 168
No news ?

_________________
Sam460ex
Os4.1 Final Edition
2GB Fast Memory
HD R9 TRIX 280X 3GO
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2007/3/19 13:44
From Up Rough
Posts: 167
Hi,

I'll post a second beta this evening with a fix for the keyboard problem, I'll check the problem with the samples speed too. Sorry about the delay, I have been very busy this month.

Varthall

_________________
AmigaOne XE - AmigaOS 4.1 - Freescale 7457 1GHz - 1GB ram
MPlayer for OS4: https://sourceforge.net/projects/mplayer-amigaos/
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2008/3/5 16:34
From france (bretagne)
Posts: 168
@Varthall

I understand very well that you are busy and I thank you very much for your answer and future updates too !

_________________
Sam460ex
Os4.1 Final Edition
2GB Fast Memory
HD R9 TRIX 280X 3GO
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2008/3/5 16:34
From france (bretagne)
Posts: 168
@Varthall,

I wish all is oki for you...
What about a new version of Milky Tracker ? I think you're very busy so, my question is just to know if you think about it for next mounths ?

Thanks

_________________
Sam460ex
Os4.1 Final Edition
2GB Fast Memory
HD R9 TRIX 280X 3GO
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2007/3/19 13:44
From Up Rough
Posts: 167
I hope this time to make it :) A second beta with just a minor bugfix for a start, the keyboard should work correctly now:

https://docs.google.com/uc?export=down ... qDqDmouu0zZl9tU0otSHY5cjQ

Regarding the octave down/up issue, are you using the note transposing or is this related to the keyboard issue too?

Please let me know of any other issue (except for the AmigaOS devices change in the requesters and the general GUI slugginess).

Varthall


Edited by Varthall on 2014/7/4 7:13:01
_________________
AmigaOne XE - AmigaOS 4.1 - Freescale 7457 1GHz - 1GB ram
MPlayer for OS4: https://sourceforge.net/projects/mplayer-amigaos/
   Report Go to top

Re: Bug in Milky-Tracker :-(
Just popping in
Joined:
2008/3/5 16:34
From france (bretagne)
Posts: 168
@Varthall

Hey, Thanks a lot !
All seems to work perfectly now.. But i must take a little more time to test your nex beta Version. I'm going to made a new mod in a few days so, I'll bring you some informations or/issues.
Thanks thanks thanks !

_________________
Sam460ex
Os4.1 Final Edition
2GB Fast Memory
HD R9 TRIX 280X 3GO
   Report Go to top


(1) 2 3 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project