Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
112 user(s) are online (87 user(s) are browsing Forums)

Members: 1
Guests: 111

K-L, more...
Support us!
Recent OS4 Files
OS4Depot.net



« 1 2 (3)


Re: Anyone use WebDAV and want to test new handler?
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3228
@Cyborg

The WebDAV handler is in beta. The HTTP one has been public for... forever. Ten years or something!

webdav-handler was derived from http-handler but they don't share any significant code.

   Report Go to top

Re: Anyone use WebDAV and want to test new handler?
Just popping in
Joined:
2006/12/22 10:43
From Germany
Posts: 177
hmm .. so do I need to wait for webdav-handler or can I mount my WebDAV share with the http-handler as well? If the latter, what is the point in webdav-handler anyway?

Sorry, I'm a bit confused now about the purpose of those.

_________________
AmigaOS 4 core developer
www.os4welt.de - Die deutsche AmigaOS 4 Gemeinschaft

"In the beginning was CAOS.."
-- Andy Finkel, 1988 (ViewPort article, Oct. 1993)
   Report Go to top

Re: Anyone use WebDAV and want to test new handler?
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3228
@Cyborg

You can mount your WebDAV share with the webdav-handler beta. The version I'm using thinks files that don't exist exist, so be careful - especially when deleting files - as I don't remember what state the public one is in (may be the same)

http-handler only accesses files hosted on HTTP and HTTPS, it doesn't work as a browsable filesystem.

Conversely, you can't use webdav-handler to access random HTTP locations, it will only connect to configured WebDAV shares.

The reason they are part of the same project is because originally I planned to (and, in fact, did) add WebDAV support to http-handler. The resultant buggy mess ended up getting scrapped and re-written purely for WebDAV use, leaving the original http-handler on the old pre-WebDAV code base.

Incidentally this is why webdav-handler is v3.x rather than 1.x (2.x was the earlier one I abandoned)

If somebody wants to take this over and fix it up, let me know. I don't have much motivation to do anything with it as I tend to use a local Samba share these days.

   Report Go to top


« 1 2 (3)



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project