Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
66 user(s) are online (49 user(s) are browsing Forums)

Members: 0
Guests: 66

more...
Support us!
Recent OS4 Files
OS4Depot.net



« 1 (2) 3 4 5 ... 30 »


Re: Mplayer Altivec test version for G4 and PA6T-1682M
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 5526
@LiveForIt
Quote:

What computer are you testing on X1000, XE or Pegasus II?
What graphic card do you have and what port is connected to? PCIe, PCI 66Mhz, PCI 33Mhz :-p


I am on peg2/1ghz with radeon9250.

Quote:

What video are you testing?


That some small avi video (10mb), which are:
Quote:

[DIVX] 480x360 24bpp 29.970 fps 626.4 kbps (76.5 kbyte/s)



Quote:

Can you run snoopy to see what what file it try to open, I don't have that problem on my computer.


Maybe you run it from "sh" ? I can't post right now log from snoopy (as i have some beta which crashes), but i was lucky enough to catch something one time that its indeed your build trying to open directly those patches with "/" at begining. I.e. /progdir/blabalb and so on. Like you use some unix patches or so.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 5526
@ddni
Quote:

Using the first release from liveforit, I ran a 480p .avi of GForce and only got 9% CPU usage on my X1000.
This was without any command line modifier, just the exe and file name.


Use command line to specify what driver to use, that will be easy for all of us to see differences. Just "mplayer -vo cgx_wpa video.avi": for cgx_wpa, or "mplayer -vo comp video.avi" for compositing.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2734
@K-L

Quote:
I only get a grey screen with 100% CPU USage.


this clear indicator that hardware composition is not supported on your graphic card.

The version of mplayer I have compiled only supported hardware composition and not software composition.

I can make it a fallback on software bit operation, so it does give you gray screen, but the speed will suffer.

Picasso96 Overlay is only option as long hardware composition is not supported.


_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2008/4/10 13:57
From Northern Ireland
Posts: 901
@kas1e

Will do. The video played perfectly without any command line though and only 9% cpu load.

Will retest with the command line modifiers.
It would be great if we all had the same video to test too.

_________________
AmigaOne X1000.
Radeon R9 270X

http://www.tinylife.org.uk/
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 5526
@LiveForIt

Btw, i notice that with compositing driver when i move window with video inside, its "blink by grey" and i can see some white strips on few millyseconds. Looks like when back in times we miss WaitTOF or dbl-buffering, or something.

As for non-supporting compositing, imho we need add there check as we do lately in p96 driver for overlay, but for compositing : i.e. check if hw compositing avail or not, and if not, then just return -1 , so next driver in list will be taken.

So, our list can looks like this in end:

1. Overlay (if nope, return -1 to next)
2. HW Compositing (if nope, return -1 to next)
3. cgw_wpa

So by this way we will test firstly overlay, if nope, then compositing, and if nope, then cgx_wpa.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Just can't stay away
Joined:
2006/11/29 8:09
From Lyon, France
Posts: 1005
Kas1e : form my tests (see my other thread), I would say that CGX_WPA is slower than SDL on RadeonHD while it's faster on Radeon 9xxx which is pointless since overlay is present on these cards.

Maybe it should be better this way :

1. Overlay (if nope, return -1 to next)
2. HW Compositing (if nope, return -1 to next)
3. sdl

CGX_WPA is now useless.

LiveForIt : using -vo comp on X1000, some videos are trashed while they are ok with -vo sdl

Weird that my 9000Pro doesn't support composition since I can use WaZp3D with Compositing 2D without any trouble and really fast (for tests purposes only but anyway). But maybe it's about this hardware vs software thing you explained.

_________________
--
AmigaONE X1000 1,8Ghz, 2GB, Sapphire Radeon HD 7700, with Amiga OS 4.1 FE
http://www.amiga-ng.org
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 5526
@K-L
Yep, overlay->compositing->sdl sounds fine. At least anyone can use cgx_wpa manually later if there will be any needs at all.

As for radeon9000pro i was sure hw compositing works on it. At least, if wazp3d with composition 2d speed things up for you, then it mean HW compositing works, as with SW compositing it should be imho even slower than without use of compositnig.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1494
@LiveForIt

Impressive !!!

Now, I'm able to play synchronized a HD video that I have never suceeded to play (with 80-95% CPU workload)

I don't really know the format of this MP4 file...

"Playing Medias:Videos/Les Cadavres - Bures - 30 avril 2011.mp4.
libavformat file format detected.
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (aac), -aid 0, -alang eng
VIDEO: [H264] 1280x720 24bpp 25.000 fps 1500.0 kbps (183.1 kbyte/s)
Clip info:
major_brand: f4v
minor_version: 0
compatible_brands: isommp42m4v
creation_time: 2011-07-30 00:15:04
VO: [cgx_wpa] Welcome man !.
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, s16be, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
ahi_dev_init:511
-- driver -- 4B6DE514
AO: [ahi_dev] 44100Hz 2ch s16be (2 bytes per sample)
Starting playback...
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [comp] 1280x720 => 1280x720 Planar YV12
Open_Window:289 -- Task 0x4E3D81C0
"

Standard avi files works very well with very few CPU workload.

Bravo


Just 2 things :
-as "-cache" option is not supported, it seems that 480p video are not synchronised with SMTube (MickJT Mplayer handles them thanks to -cache)

-when Pause is pressed (space bar) the sound stops 2-3 seconds after that the video is paused.


2014 looks like very good for AOS4 (Odyssey, MPlayer...)
Merci

   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2009/6/1 13:11
From Germany
Posts: 733
@zzd10h
Whoaahhh SMTube works pretty well
720HD and 1080HD works but a little bit to slow.
My CPU usage is at 87% so there is room to play
How can i start a movie?I'm not an expert of the shell

_________________
Amiga600/Vampire2/PrismaMegaMix​/32GB CF Card/2x Rys Mk2/A604n/IndivisionECS/Gotek
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2008/4/10 13:57
From Northern Ireland
Posts: 901
Open shell
Drag exe onto shell, type in one of the command lines above,
Drag movie file onto shell
Hit return.

Pray then hope

_________________
AmigaOne X1000.
Radeon R9 270X

http://www.tinylife.org.uk/
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2009/6/1 13:11
From Germany
Posts: 733
@ddni
I tried some 720HD and 1080 HD movies, they are a little bit to slow , they works in fullscreen

_________________
Amiga600/Vampire2/PrismaMegaMix​/32GB CF Card/2x Rys Mk2/A604n/IndivisionECS/Gotek
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2009/6/1 13:11
From Germany
Posts: 733
I tried some 1080HD videos with SMPlayer.
I think there is only 20 percent missing , that let it play absolute smoothly

_________________
Amiga600/Vampire2/PrismaMegaMix​/32GB CF Card/2x Rys Mk2/A604n/IndivisionECS/Gotek
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2734
@tommysammy

Who knows maybe its possible to get a few % more.

Shame we don't have hardware accelerated video decoding.

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2009/6/1 13:11
From Germany
Posts: 733
@LiveForIt
I am looking now Sci-Fi Short Film 1080HD Lunar by Tyson Wade Johnston over SMTube in 1080 HD !!!
This movie works very smooth here

_________________
Amiga600/Vampire2/PrismaMegaMix​/32GB CF Card/2x Rys Mk2/A604n/IndivisionECS/Gotek
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3145
@LiveForIt

About Altivec version on not supported machines (Sam440 for example) i just try the original Reaction MPlayer (Altivec) and it crash aswell (no warning message, just a direct crash)

Quote:
Stack trace:
module MPlayer at 0x6F4DD610 (section 5 @ 0x125EC)
module MPlayer at 0x6F4DD8EC (section 5 @ 0x128C8)
native kernel module newlib.library.kmod+0x000020ac
native kernel module newlib.library.kmod+0x00002d5c
native kernel module newlib.library.kmod+0x00002ef0
_start()+0x180 (section 1 @ 0x17C)
native kernel module dos.library.kmod+0x00024cd0
native kernel module kernel+0x0003b4b0
native kernel module kernel+0x0003b530


Your version instead give me a DSI at address: 0x6cbf297c (task: 0x558aea90 "MPlayer")
Can't skip that one, only things to do is a reboot.

Aniway as you done your current work i hope you can compile also a not-altivec version to test so we can test the real things, meanwhile i just sent an e-mail to Varthall to let you the access to the Google site, let's hope he will reply !

   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2009/4/28 3:57
From Adelaide, Australia
Posts: 929
@zzd10h

Does -cache have an effect when just playing files locally from the HDD? I thought it was for networking streaming only, but perhaps it is used for both.

   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Just can't stay away
Joined:
2006/11/24 18:52
From Gloucestershire, UK.
Posts: 1169
Just tried -vo comp on my X1000 (R5450HD) and the video isn't displaying correctly, lots of diagonal lines across the display like when you had to make adjustments to rip gfx out of ram on a classic. I can do a screen grab if needed.

I also get the "Please insert volume /progdir/conf/<volumename>:" error if the file is in the root.


_________________
Amiga user since 1985
AOS4, A-EON, IBrowse & Alinea Betatester

Ps. I hate the new amigans website. <shudder>
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2008/4/10 13:57
From Northern Ireland
Posts: 901
Like Severin, -vo comp gives me diagonal lines across the video.

_________________
AmigaOne X1000.
Radeon R9 270X

http://www.tinylife.org.uk/
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Just can't stay away
Joined:
2006/12/9 10:44
From Lyon, France
Posts: 1335
@Liveforit

Hum, could you compile a version without Alitivec for those of us that don't have it?
Thanks.

_________________
Philippe 'Elwood' FERRUCCI
Sam460ex 1.10 Ghz
http://elwoodb.free.fr
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1494
@MickJT

Yes, when I spoke about "-cache", it was for SMTube videos, therefore streaming.

@TommySammy

Really ? 1080p smooth with LiveForIt's Mplayer and SMTube ???

   Report Go to top


« 1 (2) 3 4 5 ... 30 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project