Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
47 user(s) are online (33 user(s) are browsing Forums)

Members: 0
Guests: 47

more...
Support us!
Recent OS4 Files
OS4Depot.net



« 1 ... 5 6 7 (8) 9 10 11 ... 13 »


Re: Getting Napalm to run on AmigaOS 4.1.2?
Just can't stay away
Joined:
2006/11/30 11:30
From Finland
Posts: 1689
@Cool_amigaN

Does CDDA playing work with PlayCDDA (set DOSDEV tooltype to CD0: or whatever your CD/DVD drive is)?

As for Exodus have you configured the device and unit for CDDA playback correctly? Device should be sii3114ide.device for Sam440EP IIRC. For unit number you can just type in "idetool -l sii3114ide.device" to see what unit the CD/DVD drive is attached to.

   Report Go to top

Re: Getting Napalm to run on AmigaOS 4.1.2?
Just can't stay away
Joined:
2006/11/30 11:30
From Finland
Posts: 1689
@Cool_amigaN

Are you sure that Exodus uses cdplayer.library? At least the demo version I have (from AFCD48) doesn't, instead it seems to use it's own internal routines.

   Report Go to top

Re: Getting Napalm to run on AmigaOS 4.1.2?
Just popping in
Joined:
2006/12/26 19:11
From Athens/Greece
Posts: 143
Quote:

salass00 wrote:
@Cool_amigaN

Are you sure that Exodus uses cdplayer.library? At least the demo version I have (from AFCD48) doesn't, instead it seems to use it's own internal routines.


Well... no :P I have not idea if it uses cdplayer lib. How can I find it? Still, I can assure you that music (not sound effects but music) on the full version doesn't play and other ppl have reported the same with SATA DVD/CD and Exodus. I will check again regarding configuration as you instructed me and get back to you. In the meantime, I will check also some other games and report my findings :)

   Report Go to top

Re: Getting Napalm to run on AmigaOS 4.1.2?
Just popping in
Joined:
2006/12/26 19:11
From Athens/Greece
Posts: 143
Quote:

salass00 wrote:
@Cool_amigaN

Does CDDA playing work with PlayCDDA (set DOSDEV tooltype to CD0: or whatever your CD/DVD drive is)?

As for Exodus have you configured the device and unit for CDDA playback correctly? Device should be sii3114ide.device for Sam440EP IIRC. For unit number you can just type in "idetool -l sii3114ide.device" to see what unit the CD/DVD drive is attached to.


OK checket it. Music of Exodus plays fine with playcdda_gui.

As for Exodus everything is setup correctly (device name and number).

Still no music ingame using the new cdplayer lib.

I am gonna now check using latest patch of Napalm along with your lib.

   Report Go to top

Re: Getting Napalm to run on AmigaOS 4.1.2?
Just popping in
Joined:
2008/12/20 13:58
Posts: 185
@salass00
For what ever reason your library has given me CD Audio once on the second attempt with Wipeout but has failed to give me music on all other attempts, it starts accessing the CD each time as if it is reading the CD Audio but I don't get any CD Audio which is a bit odd.

_________________
Sam440ep 667mhz 512megs OS4.1 + Minimig, 4MB RAM, ARM add-on board
WinUae 2.3.2, OS 3.9, BB2, Catweasel MkIV
Amiga 1200, BlizzardPPC 060/200 with SCSI, mediatorSX, Voodoo3, pci lan
   Report Go to top

Re: Getting Napalm to run on AmigaOS 4.1.2?
Just can't stay away
Joined:
2006/11/30 11:30
From Finland
Posts: 1689
@Cool_amigaN

Quote:

Well... no :P I have not idea if it uses cdplayer lib. How can I find it?


One way without running the game is to open the executable file in a hex editor and simply do a search for the string "cdplayer.library" inside it. If you don't find it then it's most likely not using it.

Another test to make is to run Snoopy and check for "OpenLibrary("cdplayer.library", ...)" in the log.

   Report Go to top

Re: Getting Napalm to run on AmigaOS 4.1.2?
Just can't stay away
Joined:
2006/11/30 11:30
From Finland
Posts: 1689
For anyone who's having problems with a specific program and cdplayer.library there is now a debug version of cdplayer.library here:
http://dl.dropbox.com/u/26599983/cdplayer_lib-debug.7z

Please send a dump of the debug info (obtained using Sashimi or C:DumpDebugBuffer) and I might be able to see what is going wrong and fix it.

Of course make sure first that the program uses the correct CDDA device and unit data (check for OpenDevice calls in Snoopy f.e.). Some old, badly written programs like f.e. this CDPlay program are hardcoded to use scsi.device and in this case there is unfortunately not much that one can do.

   Report Go to top

Re: Getting Napalm to run on AmigaOS 4.1.2?
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3227
Quote:

salass00 wrote:
Some old, badly written programs like f.e. this CDPlay program are hardcoded to use scsi.device and in this case there is unfortunately not much that one can do.


scsi.device can be remapped using nsdpatch.cfg - I believe the settings to do this are present by default on a new OS4 install.

   Report Go to top

Re: Getting Napalm to run on AmigaOS 4.1.2?
Just can't stay away
Joined:
2006/11/30 11:30
From Finland
Posts: 1689
@Chris

I already use NSDPatch to redirect trackdisk.device units 0-3 to diskimage.device. I meant more as in not much can be done in cdplayer.library.

I'd also like to add that CDPlay isn't just hardcoded to scsi.device it's also hardcoded to unit 2 of this device (not that it makes much difference if you're going to be remapping it with NSDPatch).

   Report Go to top

Re: Getting Napalm to run on AmigaOS 4.1.2?
Just popping in
Joined:
2006/12/26 19:11
From Athens/Greece
Posts: 143
Quote:

salass00 wrote:
@Cool_amigaN

Quote:

Well... no :P I have not idea if it uses cdplayer lib. How can I find it?


One way without running the game is to open the executable file in a hex editor and simply do a search for the string "cdplayer.library" inside it. If you don't find it then it's most likely not using it.

Another test to make is to run Snoopy and check for "OpenLibrary("cdplayer.library", ...)" in the log.


Did my search with snoopy. I didn't find ant cdplayer.library reported, as you had already suggested. The only affifliated with sound/music I found were some FAILed output on AHI when swaping channels though, I don't know if that helps. Anyway, I am gonna check with Napalm today or tomorrow.

   Report Go to top

Re: Getting Napalm to run on AmigaOS 4.1.2?
Just popping in
Joined:
2008/12/20 13:58
Posts: 185
Quote:

salass00 wrote:
@Chris

I already use NSDPatch to redirect trackdisk.device units 0-3 to diskimage.device. I meant more as in not much can be done in cdplayer.library.

I'd also like to add that CDPlay isn't just hardcoded to scsi.device it's also hardcoded to unit 2 of this device (not that it makes much difference if you're going to be remapping it with NSDPatch).

even with the remapping I can't get any sound out of CDPlay.

here is a dump of my the debugbuffer on my sam440ep with AHI setup to use the onboard audio on my sam440ep mini-itx board:

msr = 0x00001030
[keybdevLIBInit] LibInit of keyboard device
Scanning bus 'dvi'
0000: 00 FF FF FF FF FF FF 00 22 83 8C 17 69 03 00 00 ........"...i...
0010: 2D 0C 01 03 81 22 1B 78 EA CF C6 A3 57 47 9E 23 -....".x....WG.#
0020: 12 4F 54 BF EF 00 81 80 01 01 01 01 01 01 01 01 .OT.............
0030: 01 01 01 01 01 01 30 2A 00 98 51 00 2A 40 30 70 ......0*..Q.*@0p
0040: 13 00 52 0E 11 00 00 1E 00 00 00 FD 00 38 4B 18 ..R..........8K.
0050: 50 0E 00 0A 20 20 20 20 20 20 00 00 00 FC 00 43 P..............C
0060: 4D 4C 31 37 34 53 58 0A 20 20 20 20 00 00 00 FF ML174SX.........
0070: 00 48 32 4B 30 30 30 38 37 33 0A 20 20 20 00 34 .H2K000873.....4
EDID V1.3
ManufacturerID HTC ProductID 178C
SerialNo 873 Manufactured week 45 of 2002
Input type digital
Display gamma 2.20
Maximum Image Size 34x27cm
PowerManagement Standby yes Suspend yes ActiveOff yes
Monitor Name CML174SX
Serial Number H2K000873

Established timings:
800x600@60
800x600@56
640x480@75
640x480@72
640x480@67
640x480@60
720x400@70
1280x1024@75
1024x768@75
1024x768@70
1024x768@60
832x624@75
800x600@75
800x600@72

Standard Timing Identification:
1280x1024@60hz (5:4)

Mode 1280x1024@60hz 63khz
DotClock 108000000hz
HTimings 1280 1328 1440 1688
VTimings 1024 1025 1028 1066
Image Size 338x270mm
Flags progressive +hsync +vsync

Monitor Range Limits:
Horizontal frequency 24 - 80khz
Vertical frequency 56 - 75hz
Pixelclock 140Mhz
it8212ide.device 53.3 (05.02.2009)
lsi53c8xx.device 53.8 (16.1.2011)
sii0680ide.device 53.8 (16.1.2011)
sii3112ide.device 53.8 (16.1.2011)
sii3114ide.device 53.8 (16.1.2011)
[sii3114ide/mode_select] xfer mode 70 asked not supported by unit 0, trimmed to 69
[sii3114ide/mode_select] xfer mode 70 asked not supported by unit 3, trimmed to 66
sii3512ide.device 53.8 (16.1.2011)
No cards found!
No SOLO_ONE found!
No SB128 found!
No FM801 found!
No Envy24HT found!
No Envy24 found!
No CMI8738 found!
libInit()
Success
libOpen(37)
OpenCnt: 1
CDReadTOC(0x5A1DFAD8, 0x5A137D50)
CDReadTOC return: 0
CDTitleTime(0x5A1DFCCE, 0x5A137D50)
CDReadTOC(0x5A089BB0, 0x5A137D50)
CDReadTOC return: 0
CDTitleTime return: 0
CDInfo(0x5A1DFCEA, 0x5A137D50)
CDInfo return: 0
CDPlay(1, 12, 0x5A137D50)
CDReadTOC(0x5A089BB6, 0x5A137D50)
CDReadTOC return: 0
CDPlay return: -5
CDResume(0, 0x5A137D50)
CDResume return: 0
CDPlay(1, 12, 0x5A137D50)
CDReadTOC(0x5A089BB6, 0x5A137D50)
CDReadTOC return: 0
CDPlay return: -5
CDPlay(1, 12, 0x5A137D50)
CDReadTOC(0x5A089BB6, 0x5A137D50)
CDReadTOC return: 0
CDPlay return: -5
CDPlay(1, 12, 0x5A137D50)
CDReadTOC(0x5A089BB6, 0x5A137D50)
CDReadTOC return: 0
CDPlay return: -5
CDPlay(1, 12, 0x5A137D50)
CDReadTOC(0x5A089BB6, 0x5A137D50)
CDReadTOC return: 0
CDPlay return: -5
CDStop(0x5A137D50)
CDStop return: 0
CDPlay(2, 12, 0x5A137D50)
CDReadTOC(0x5A089BB6, 0x5A137D50)
CDReadTOC return: 0
CDPlay return: -5
CDPlay(1, 12, 0x5A137D50)
CDReadTOC(0x5A089BB6, 0x5A137D50)
CDReadTOC return: 0
CDPlay return: -5
CDPlay(2, 12, 0x5A137D50)
CDReadTOC(0x5A089BB6, 0x5A137D50)
CDReadTOC return: 0
CDPlay return: -5
CDStop(0x5A137D50)
CDStop return: 0
CDPlay(2, 12, 0x5A137D50)
CDReadTOC(0x5A089BB6, 0x5A137D50)
CDReadTOC return: 0
CDPlay return: -5
CDPlay(2, 12, 0x5A137D50)
CDReadTOC(0x5A089BB6, 0x5A137D50)
CDReadTOC return: 0
CDPlay return: -5
CDResume(1, 0x5A137D50)
CDResume return: 0
CDResume(0, 0x5A137D50)
CDResume return: 0
CDPlay(3, 12, 0x5A137D50)
CDReadTOC(0x5A089BB6, 0x5A137D50)
CDReadTOC return: 0
CDPlay return: -5
CDPlay(4, 12, 0x5A137D50)
CDReadTOC(0x5A089BB6, 0x5A137D50)
CDReadTOC return: 0
CDPlay return: -5
CDStop(0x5A137D50)
CDStop return: 0
CDStop(0x5A137D50)
CDStop return: 0
CDStop(0x5A137D50)
CDStop return: 0
CDStop(0x5A137D50)
CDStop return: 0
CDPlay(4, 12, 0x5A137D50)
CDReadTOC(0x5A089BB6, 0x5A137D50)
CDReadTOC return: 0
CDPlay return: -5
CDResume(1, 0x5A137D50)
CDResume return: 0
CDResume(0, 0x5A137D50)
CDResume return: 0
libClose()
OpenCnt: 0



_________________
Sam440ep 667mhz 512megs OS4.1 + Minimig, 4MB RAM, ARM add-on board
WinUae 2.3.2, OS 3.9, BB2, Catweasel MkIV
Amiga 1200, BlizzardPPC 060/200 with SCSI, mediatorSX, Voodoo3, pci lan
   Report Go to top

Re: Getting Napalm to run on AmigaOS 4.1.2?
Just popping in
Joined:
2008/12/20 13:58
Posts: 185
and here is the buffer dump from wipeout2097:


msr = 0x00001030
[keybdevLIBInit] LibInit of keyboard device
Scanning bus 'dvi'
0000: 00 FF FF FF FF FF FF 00 22 83 8C 17 69 03 00 00 ........"...i...
0010: 2D 0C 01 03 81 22 1B 78 EA CF C6 A3 57 47 9E 23 -....".x....WG.#
0020: 12 4F 54 BF EF 00 81 80 01 01 01 01 01 01 01 01 .OT.............
0030: 01 01 01 01 01 01 30 2A 00 98 51 00 2A 40 30 70 ......0*..Q.*@0p
0040: 13 00 52 0E 11 00 00 1E 00 00 00 FD 00 38 4B 18 ..R..........8K.
0050: 50 0E 00 0A 20 20 20 20 20 20 00 00 00 FC 00 43 P..............C
0060: 4D 4C 31 37 34 53 58 0A 20 20 20 20 00 00 00 FF ML174SX.........
0070: 00 48 32 4B 30 30 30 38 37 33 0A 20 20 20 00 34 .H2K000873.....4
EDID V1.3
ManufacturerID HTC ProductID 178C
SerialNo 873 Manufactured week 45 of 2002
Input type digital
Display gamma 2.20
Maximum Image Size 34x27cm
PowerManagement Standby yes Suspend yes ActiveOff yes
Monitor Name CML174SX
Serial Number H2K000873

Established timings:
800x600@60
800x600@56
640x480@75
640x480@72
640x480@67
640x480@60
720x400@70
1280x1024@75
1024x768@75
1024x768@70
1024x768@60
832x624@75
800x600@75
800x600@72

Standard Timing Identification:
1280x1024@60hz (5:4)

Mode 1280x1024@60hz 63khz
DotClock 108000000hz
HTimings 1280 1328 1440 1688
VTimings 1024 1025 1028 1066
Image Size 338x270mm
Flags progressive +hsync +vsync

Monitor Range Limits:
Horizontal frequency 24 - 80khz
Vertical frequency 56 - 75hz
Pixelclock 140Mhz
it8212ide.device 53.3 (05.02.2009)
lsi53c8xx.device 53.8 (16.1.2011)
sii0680ide.device 53.8 (16.1.2011)
sii3112ide.device 53.8 (16.1.2011)
sii3114ide.device 53.8 (16.1.2011)
[sii3114ide/mode_select] xfer mode 70 asked not supported by unit 0, trimmed to 69
[sii3114ide/mode_select] xfer mode 70 asked not supported by unit 3, trimmed to 66
sii3512ide.device 53.8 (16.1.2011)
No cards found!
No SOLO_ONE found!
No SB128 found!
No FM801 found!
No Envy24HT found!
No Envy24 found!
No CMI8738 found!

_________________
Sam440ep 667mhz 512megs OS4.1 + Minimig, 4MB RAM, ARM add-on board
WinUae 2.3.2, OS 3.9, BB2, Catweasel MkIV
Amiga 1200, BlizzardPPC 060/200 with SCSI, mediatorSX, Voodoo3, pci lan
   Report Go to top

Re: Getting Napalm to run on AmigaOS 4.1.2?
Just can't stay away
Joined:
2006/11/30 11:30
From Finland
Posts: 1689

   Report Go to top

Re: Getting Napalm to run on AmigaOS 4.1.2?
Just popping in
Joined:
2008/12/20 13:58
Posts: 185
@salass00
OK the good news is your new version gives me working audio with CDPlay and I can confirm AHI is being used as muting the CD channel still gives me music.

Now for the odd bit it also seems to give me working music with Wipeout but only when I use CDPlay to play a CD first then wipeout has working CD audio and I can change tune from the music menu, but the audio does not seem to be playing using AHI as muting the CD Audio channel mutes the music.

_________________
Sam440ep 667mhz 512megs OS4.1 + Minimig, 4MB RAM, ARM add-on board
WinUae 2.3.2, OS 3.9, BB2, Catweasel MkIV
Amiga 1200, BlizzardPPC 060/200 with SCSI, mediatorSX, Voodoo3, pci lan
   Report Go to top

Re: Getting Napalm to run on AmigaOS 4.1.2?
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2735
Quote:
I'd also like to add that CDPlay isn't just hardcoded to scsi.device it's also hardcoded to unit 2 of this device (not that it makes much difference if you're going to be remapping it with NSDPatch).


PlayCD as tooltypes on the icon, don't know if this work or not.

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: Getting Napalm to run on AmigaOS 4.1.2?
Just can't stay away
Joined:
2006/11/30 11:30
From Finland
Posts: 1689
@Dwyloc

Sounds like there is an old version of cdplayer.library in Wipeout's program directory. In that case it will be used instead of the one in LIBS: unless the newer version has already been loaded by something else, i.e. CDPlay in your case.

   Report Go to top

Re: Getting Napalm to run on AmigaOS 4.1.2?
Just can't stay away
Joined:
2006/11/30 11:30
From Finland
Posts: 1689
cdplayer.library v52.2 is now available which fixes some bugs in previous version:
http://www.a500.org/downloads/libraries/cdplayer_lib_7z.readme

   Report Go to top

Re: Getting Napalm to run on AmigaOS 4.1.2?
Home away from home
Joined:
2007/5/19 13:23
From England
Posts: 3553
It's much easier to download it from OS4Depot, as I can actually unpack LHA (but not 7zip) archives...
http://os4depot.net/?function=showfil ... ry/audio/cdplayer_lib.lha

_________________
Author of the PortablE programming language.
I love using Amiga OS4.1
It is pitch black. You are likely to be eaten by a grue...
   Report Go to top

Re: Getting Napalm to run on AmigaOS 4.1.2?
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3227

   Report Go to top

Re: Getting Napalm to run on AmigaOS 4.1.2?
Just can't stay away
Joined:
2006/11/30 11:30
From Finland
Posts: 1689
cdplayer.library v52.3 is now uploaded to the usual places.

Reason for this quick update is that in the code I had the following mistake:
if (cdda_addr = (ULONG)-1) {
   
cdda_addr addr;
}


The first line should of course be a comparison ("==") and not an assignment ("="). As it was, it was always setting cdda_addr variable to be the same as addr.

   Report Go to top


« 1 ... 5 6 7 (8) 9 10 11 ... 13 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project