Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
86 user(s) are online (79 user(s) are browsing Forums)

Members: 0
Guests: 86

more...
Support us!
Recent OS4 Files
OS4Depot.net





RadeonRX 570 8GB questions
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 5529
@All
Is anyone use this kind of card on amigaos4 ? I buy today "MSI AMD Radeon RX 570 ARMOR OC 8 GB DDR5", and notice 2 issues with it at moment:

1). Sysmon show for graphics card that:

Card Name : Radeon RX Polaris10
Free mem: 217mb
Used mem: 25mb
Free GPU: 7936
Used GPU: 0
Total mem: 4082 mb

So while i have 8gb of GPU memory, it still show that total mem is 4082, and when i fill GPU more than on 4gb by data, it then behave badly and give visuall distortions.

Is it expected that only 4gb of GPU memory are usable ?

2). While simple tests works (like filling of video memory by data), or Warp3DLogo works. The other examples didn't works. For example if i just run "W3DNBitMapCube", then nothing happens and on serial i have tons of that:

RadeonRX (0): Wait done 24898 timed out (execID24897lastSubmitID24898sID24900). GPU busy
RadeonRX 
(0):   mmGRBM_STATUS0xB16D0028
RadeonRX 
(0):   mmGRBM_STATUS20x50000008
RadeonRX 
(0):   mmGRBM_STATUS_SE00x28000000
RadeonRX 
(0):   mmGRBM_STATUS_SE10x28000000
RadeonRX 
(0):   mmGRBM_STATUS_SE20x28000000
RadeonRX 
(0):   mmGRBM_STATUS_SE30x28000000
RadeonRX 
(0):   mmPA_CL_CNTL_STATUS0x00000000
RadeonRX 
(0):   mmPA_SU_CNTL_STATUS0x00000000
RadeonRX 
(0):   mmSQ_THREAD_TRACE_STATUS0x80000000
RadeonRX 
(0): Wait done 24898 timed out (execID24897lastSubmitID24898sID24900). GPU busy
RadeonRX 
(0):   mmGRBM_STATUS0xB16D0028
RadeonRX 
(0):   mmGRBM_STATUS20x50000008
RadeonRX 
(0):   mmGRBM_STATUS_SE00x28000000
RadeonRX 
(0):   mmGRBM_STATUS_SE10x28000000
RadeonRX 
(0):   mmGRBM_STATUS_SE20x28000000
RadeonRX 
(0):   mmGRBM_STATUS_SE30x28000000
RadeonRX 
(0):   mmPA_CL_CNTL_STATUS0x00000000
RadeonRX 
(0):   mmPA_SU_CNTL_STATUS0x00000000
RadeonRX 
(0):   mmSQ_THREAD_TRACE_STATUS0x80000000
RadeonRX 
(0): GFX ring hungPerforming a GPU reset
RadeonRX 
(0): amdgpuring 0 test failed (scratch(0xC040)=0xCAFEDEAD)
RadeonRX (0): KCQ enable failed (scratch(0xC040)=0xCAFEDEAD)
RadeonRX (0): KCQ enable failed (scratch(0xC040)=0xCAFEDEAD)
RadeonRX (0): GFX ring unavailableAborting.
RadeonRX (0): Wait idle timed outGPU busy


Then i tried debug version of RadeonRX driver, and that what i have if for example run "W3DNTextureCube":

RadeonRX (0): Wait done 31866 timed out (execID31865lastSubmitID31866sID31868). GPU busy
RadeonRX 
(0):   mmGRBM_STATUS0xB16D0028
RadeonRX 
(0):   mmGRBM_STATUS20x50000008
RadeonRX 
(0):   mmGRBM_STATUS_SE00x28000000
RadeonRX 
(0):   mmGRBM_STATUS_SE10x28000000
RadeonRX 
(0):   mmGRBM_STATUS_SE20x28000000
RadeonRX 
(0):   mmGRBM_STATUS_SE30x28000000
RadeonRX 
(0):   mmPA_CL_CNTL_STATUS0x00000000
RadeonRX 
(0):   mmPA_SU_CNTL_STATUS0x00000000
RadeonRX 
(0):   mmSQ_THREAD_TRACE_STATUS0x80000000
RadeonRX 
(0): Wait done 31866 timed out (execID31865lastSubmitID31866sID31868). GPU busy
RadeonRX 
(0):   mmGRBM_STATUS0xB16D0028
RadeonRX 
(0):   mmGRBM_STATUS20x50000008
RadeonRX 
(0):   mmGRBM_STATUS_SE00x28000000
RadeonRX 
(0):   mmGRBM_STATUS_SE10x28000000
RadeonRX 
(0):   mmGRBM_STATUS_SE20x28000000
RadeonRX 
(0):   mmGRBM_STATUS_SE30x28000000
RadeonRX 
(0):   mmPA_CL_CNTL_STATUS0x00000000
RadeonRX 
(0):   mmPA_SU_CNTL_STATUS0x00000000
RadeonRX 
(0):   mmSQ_THREAD_TRACE_STATUS0x80000000
RadeonRX 
(0): Wait done 31866 timed out (execID31865lastSubmitID31866sID31868). GPU busy
RadeonRX 
(0):   mmGRBM_STATUS0xB16D0028
RadeonRX 
(0):   mmGRBM_STATUS20x50000008
RadeonRX 
(0):   mmGRBM_STATUS_SE00x28000000
RadeonRX 
(0):   mmGRBM_STATUS_SE10x28000000
RadeonRX 
(0):   mmGRBM_STATUS_SE20x28000000
RadeonRX 
(0):   mmGRBM_STATUS_SE30x28000000
RadeonRX 
(0):   mmPA_CL_CNTL_STATUS0x00000000
RadeonRX 
(0):   mmPA_SU_CNTL_STATUS0x00000000
RadeonRX 
(0):   mmSQ_THREAD_TRACE_STATUS0x80000000


That all on RadeonRX 1.12.

Tried also versions 1.10 and 1.11 : the same results.

I tried then and without compositing, and without interrupts : all the same.

Tried also with some previous version of warp3dnova : still the same.

Anyone tried such cards ?

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: RadeonRX 570 8GB questions
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 5529
@All
Created 2 bugreports about:

1
Non working in 3D when it more than just some simple things:

http://www.amiga.org/developer/bugreports/view.php?id=454

2
Only 4gb of 8gb of extendent GPU memory can be used:

http://www.amiga.org/developer/bugreports/view.php?id=456

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top





[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project