Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
61 user(s) are online (47 user(s) are browsing Forums)

Members: 0
Guests: 61

more...
Support us!
Recent OS4 Files
OS4Depot.net



(1) 2 »


Downloads keep failing on OSDepot
Just popping in
Joined:
2010/10/14 17:05
Posts: 108
Wjem ever I try to download files from OS4 Depot, the files almost always fail at lease once. I do not have this issue with other sites, even with much larger files.

   Report Go to top

Re: Downloads keep failing on OSDepot
Home away from home
Joined:
2006/11/26 21:45
From a story that hasn't been written yet
Posts: 3505
@Nuder_Try

Probably because it went down for maintenance or something, it still is, though

_________________
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr.
   Report Go to top

Re: Downloads keep failing on OSDepot
Quite a regular
Joined:
2007/2/27 10:47
From Gravity well
Posts: 653
@Nuder_Try

I've noticed this too, albeit I download so little that I am not sure if it's mostly failing or mostly working.

   Report Go to top

Re: Downloads keep failing on OSDepot
Not too shy to talk
Joined:
2006/11/27 8:32
From California - S.F. Bay area
Posts: 380
@Thematic

Downloads with Odyssey have been failing for me for a while now. Downloads with IBrowse works.

_________________
Look, only one leg, count em, one!
X1000/PA6T@1800MHz/2Gb/Radeon 4850

   Report Go to top

Re: Downloads keep failing on OSDepot
Just popping in
Joined:
2006/12/8 13:37
From Netherlands
Posts: 76
@sundown

I noticed that problem too with Odyssey in the last two weeks.

Today I tried again, ~10 files are ok, I had 3 files which where partially downloaded (with < ~1MB size)- after the second time downloading the failed files are fine.

   Report Go to top

Re: Downloads keep failing on OSDepot
Just popping in
Joined:
2010/10/14 17:05
Posts: 108
I noticed this back in December. Doesn't look like it's getting better.

I've not tried IBrowse there.

   Report Go to top

Re: Downloads keep failing on OSDepot
Just can't stay away
Joined:
2009/5/1 17:57
From Czech Republic
Posts: 1057
Same problem with NetSurf.

_________________
Smoke me a kipper, I'll be back for breakfast!

AmigaOne X5000 @ 2GHz / 4GB RAM / Radeon RX 560 / ESI Juli@ / AmigaOS 4.1 Final Edition
SAM440ep-flex @ 667MHz / 1GB RAM / Radeon 9250 / AmigaOS 4.1 Final Edition
   Report Go to top

Re: Downloads keep failing on OSDepot
Home away from home
Joined:
2006/11/26 21:45
From a story that hasn't been written yet
Posts: 3505
Downloads are fine here with Odyssey. Just tried with a 20 MB and 15 MB file

_________________
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr.
   Report Go to top

Re: Downloads keep failing on OSDepot
Just popping in
Joined:
2010/10/14 17:05
Posts: 108
@Raziel

I've found the issue to be only occasional. Which, in my case, usually means PEBKAC, which is why I didn't mention it right away.

   Report Go to top

Re: Downloads keep failing on OSDepot
Quite a regular
Joined:
2006/12/2 0:35
From Sydney
Posts: 685
I've been trying for the last hour to download a 4 MB file with Odyssey - failed four times with only about 100 kB loaded.

Fired up IBrowse and it worked first time, no problem. Went back and tried Oditty again - same problem.

_________________
cheers
tony
   Report Go to top

Re: Downloads keep failing on OSDepot
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 5464
I have now the same issue when trying to download some file from os4depot. Yesterday all was fine.

Its just download 100kb instead of 600kb of real file size , and then interrupts like all fine. And only the way to download its to try again to download, and to choice "resume".

First time meet with this from os4depot, seems some new problems

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: Downloads keep failing on OSDepot
Not too shy to talk
Joined:
2008/3/15 2:00
From Alberta, Canada
Posts: 296
Not sure if this is the same issue or a new one. Today I used Odyssey and downloaded some lha files from OS4Depot and every time it seemed to download ok. But when I tried to unarc the files, I got the following message for every file:

Warning: the archive file xxxxx.lha has some corrupt data!

So I downloaded the same files using IBrowse and they all unarc fine.

After reading through this thread, I tried NetSurf 3.9 and got the same results as Odyssey.

---
redfox

   Report Go to top

Re: Downloads keep failing on OSDepot
Just popping in
Joined:
2008/10/18 10:25
From Auckland, New Zealand
Posts: 100
Same problem here, for quite some time: downloads (usually large files) from os4depot with Odyssey fail. I can resume them though, and usually complete on the second try.

   Report Go to top

Re: Downloads keep failing on OSDepot
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3142
Same problem here with Odyssey, it always stopped at 100kb, but i can download using the resume functionality

   Report Go to top

Re: Downloads keep failing on OSDepot
Supreme Council
Joined:
2006/11/16 19:25
From Sweden
Posts: 3159
Been banging my head on this one for a while. And I've been unable to replicate the problem at my end.

I made some minor changes to the download script on OS4Depot today to do some additional buffer flushes. Please check if the problem persists. Also, if you can, check with a tool like wget and ibrowse.

Dunno if this is a problem on the server application side (That I just can't seem to find) or if it's a odyssey/netsurf specific problem.

_________________
Vacca foeda. Sum, ergo edo

Mr Bobo Cornwater
   Report Go to top

Re: Downloads keep failing on OSDepot
Home away from home
Joined:
2007/1/26 21:48
From New Zealand
Posts: 2196
@orgin

Does the server have a short timeout if a connection is idle?

Downloads seem to fail for me if I take too long to choose the drawer to download to. The download may complete the second time because the file requester is already in the right drawer, so I click the save button much faster.

Other browsers will continue the download even while you're choosing where to save it, but Odyssey seems to pause while you're choosing the drawer. So, maybe the server gives up too fast.

Hans

_________________
http://hdrlab.org.nz/ - Amiga OS 4 projects, programming articles and more.
https://keasigmadelta.com/ - more of my work
   Report Go to top

Re: Downloads keep failing on OSDepot
Supreme Council
Joined:
2006/11/16 19:25
From Sweden
Posts: 3159
@Hans

I changed the KeepAliveTimeout directive to 60 seconds from the default 5 seconds. Perhaps that will help in some way.

Though that shouldn't affect odyssey and netsurf getting interrupted after 100k.

_________________
Vacca foeda. Sum, ergo edo

Mr Bobo Cornwater
   Report Go to top

Re: Downloads keep failing on OSDepot
Quite a regular
Joined:
2006/12/2 0:35
From Sydney
Posts: 685
@orgin

Still just the same here - trying to download the 9 MB AISS archive with Odyssey, but I only get about 100 kB before it "fails". Tried to "Overwrite" many times, with the same result. Works OK if I try "Resume" after the failure.

Works OK with IBrowse every time, no errors.

_________________
cheers
tony
   Report Go to top

Re: Downloads keep failing on OSDepot
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 5464
@Tony
Don't forget that we have the same issue when using Netsurf too. They both use libcurl. Dunno what IBrowse use..

What is worse, is that it can't be reproduced all the time so to check it all. Sometime all fine, sometime (like for me yesterday too), it just drops after 100kb downloading. Then resuming , and all file downloads well.

Try many times with ibrowse, maybe it will fail soon or later too. Maybe its all because of some "protection" in some www-php-apache-module on server's side.

And as we didn't have that issues before and it only starts lately, it mean that all happens after some server upgrades or something.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: Downloads keep failing on OSDepot
Supreme Council
Joined:
2006/11/16 19:25
From Sweden
Posts: 3159
@tonyw

Very weird, well I'm out of ideas.

Is there any difference between the main and swedish mirror?

_________________
Vacca foeda. Sum, ergo edo

Mr Bobo Cornwater
   Report Go to top


(1) 2 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project