Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
74 user(s) are online (65 user(s) are browsing Forums)

Members: 0
Guests: 74

more...
Support us!
Recent OS4 Files
OS4Depot.net



« 1 ... 20 21 22 (23)


Re: NetSurf development builds (now with added Javascript)
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3197
HELP! I need somebody - preferably many people - with hardware other than the SAM440EP, to download the latest test build - currently 4258 and tell me (a) what hardware they have and (b) whether it starts up or not.

It is crashing on the SAM440EP but nobody else has reported any problems, so I need more reports to check if this is CPU related.

Thanks!

   Report Go to top

Re: NetSurf development builds (now with added Javascript)
Just can't stay away
Joined:
2006/11/24 18:52
From Gloucestershire, UK.
Posts: 1135
@Chris

Works fine here on my X1000 with latest beta although it's a long wait for it to scan the 2500 fonts I have installed

_________________
Amiga user since 1985
AOS4, A-EON, IBrowse & Alinea Betatester

Ps. I hate the new amigans website. <shudder>
   Report Go to top

Re: NetSurf development builds (now with added Javascript)
Just popping in
Joined:
2017/10/28 10:03
From Netherlands
Posts: 10
@Chris

Seems ok, no crashes.

X5000

   Report Go to top

Re: NetSurf development builds (now with added Javascript)
Not too shy to talk
Joined:
2006/12/1 3:20
From Michigan, USA
Posts: 379
@Chris

A1-XE G4, 2 GB memory.

Instantly freezes the computer upon trying to start the program.

Writing this with 3.7 build date 16/10/17

Paul

_________________
Builder of Frankenthousand The monster A1000
The Young Frankenthousand A1-XE G4 2GB Sii Radeon 9250 Catweasel MKIII NEC USB2 OS 4.1FE Update 1
   Report Go to top

Re: NetSurf development builds (now with added Javascript)
Just popping in
Joined:
2017/10/28 10:03
From Netherlands
Posts: 10
@Chris

I dont think the Javascript is working... even when the javascript checkbox is selected.


   Report Go to top

Re: NetSurf development builds (now with added Javascript)
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3197
@Skateman

Try https://javatester.org/javascript.html

@all

OK, currently it is working on:
X1000, X5000

Not working on:
A1 G4-XE, SAM 440EP

Not Altivec then! I thought it might be an alignment issue, but this probably rules that out too. Anyone else?

Ah, just spotted something. *crosses fingers*
edit Nope, didn't work.


Edited by Chris on 2017/12/10 21:03:56
   Report Go to top

Re: NetSurf development builds (now with added Javascript)
Not too shy to talk
Joined:
2006/11/28 22:14
From Perugia, ITALY
Posts: 337
Here Pegasos2 G4 ith AmigaOS4.1FE
After trying to skip DSI I get that ISI:

Quote:

Crash log for task "NetSurf"
Generated by GrimReaper 53.19
Crash occured in module at address 0x0000004C
Type of crash: ISI (Instruction Storage Interrupt) exception
Alert number: 0x80000003

Register dump:
GPR (General Purpose Registers):
0: 7CDAF4E0 54D1D3C0 9101000C 00000000 18EC962C 54D1D398 00000000 8BC7C380
8: 00000001 0000004E 00000001 0184ACF0 37933995 5665BB20 68A94350 5663B680
16: 7CDAF274 567E0000 565142A4 51C51BB8 51C51BC4 567E0000 51DEBF5C 00000000
24: 567E0000 00000000 567E29D4 54C77198 56415EC2 553D0C60 00000000 54C88440


FPR (Floating Point Registers, NaN = Not a Number):
0: nan 1042 398 1042
4: 374 1054.8 627.8 1042
8: 374 1 1054.8 255
12: nan 65536 0 0
16: 0 0 0 0
20: 0 0 0 0
24: 0 0 0 0
28: 0 0 0 0

FPSCR (Floating Point Status and Control Register): 0x82004000


SPRs (Special Purpose Registers):
Machine State (msr) : 0x1200F030
Condition (cr) : 0x51C16DA0
Instruction Pointer (ip) : 0x0000004C
Xtended Exception (xer) : 0x01827214
Count (ctr) : 0x00000000
Link (lr) : 0x00000000
DSI Status (dsisr) : 0x01846994
Data Address (dar) : 0x00000000



680x0 emulated registers:
DATA: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
ADDR: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
FPU0: 0 0 0 0
FPU4: 0 0 0 0



Symbol info:
Instruction pointer 0x0000004C belongs to module "" (HUNK/Kickstart)

Stack trace:
0x0000004C symbol not available
[frontends/amiga/gui.c:996] NetSurf:main()+0x450 (section 1 @ 0x1876A0)
native kernel module newlib.library.kmod+0x00002d54
native kernel module newlib.library.kmod+0x00002ee8
NetSurf:_start()+0x170 (section 1 @ 0x16C)
native kernel module dos.library.kmod+0x000255c8
native kernel module kernel+0x00042618
native kernel module kernel+0x00042660

PPC disassembly:
00000044: XXXXXXXX illegal address
00000048: XXXXXXXX illegal address
0000004c: XXXXXXXX illegal address
00000050: XXXXXXXX illegal address
00000054: XXXXXXXX illegal address

System information:

CPU
Model: Motorola MPC 7447/7457 Apollo V1.1
CPU speed: 1133 MHz
FSB speed: 133 MHz
Extensions: performancemonitor altivec

Machine
Machine name: Pegasos II
Memory: 1048576 KB
Extensions: bus.pci bus.agp

Expansion buses
PCI/AGP
00:00.0 Vendor 0x11AB Device 0x6460
00:01.0 Vendor 0x1106 Device 0x3044
Range 0: 80002000 - 80002800 (MEM)
Range 1: 00001080 - 00001100 (IO)
00:05.0 Vendor 0x1033 Device 0x0035
Range 0: 80000000 - 80001000 (MEM)
00:05.1 Vendor 0x1033 Device 0x0035
Range 0: 80001000 - 80002000 (MEM)
00:05.2 Vendor 0x1033 Device 0x00E0
Range 0: 80002800 - 80002900 (MEM)
00:0C.0 Vendor 0x1106 Device 0x8231
00:0C.1 Vendor 0x1106 Device 0x0571
Range 0: 00001000 - 00001008 (IO)
Range 1: 00001008 - 0000100C (IO)
Range 2: 00001010 - 00001018 (IO)
Range 3: 00001018 - 0000101C (IO)
Range 4: 00001020 - 00001030 (IO)
00:0C.2 Vendor 0x1106 Device 0x3038
Range 4: 00001040 - 00001060 (IO)
00:0C.3 Vendor 0x1106 Device 0x3038
Range 4: 00001060 - 00001080 (IO)
00:0C.4 Vendor 0x1106 Device 0x8235
00:0C.5 Vendor 0x1106 Device 0x3058
Range 0: 00001100 - 00001200 (IO)
Range 1: 00001030 - 00001034 (IO)
Range 2: 00001030 - 00001034 (IO)
00:0C.6 Vendor 0x1106 Device 0x3068
Range 0: 00001200 - 00001300 (IO)
00:0D.0 Vendor 0x1106 Device 0x3065
Range 0: 00001300 - 00001400 (IO)
Range 1: 80002900 - 80002A00 (MEM)
01:00.0 Vendor 0x11AB Device 0x6460
01:08.0 Vendor 0x1002 Device 0x4966
Range 0: C0000000 - C8000000 (PREF.MEM)
Range 1: 00001000 - 00001100 (IO)
Range 2: C8000000 - C8010000 (MEM)
01:08.1 Vendor 0x1002 Device 0x496E
Range 0: D0000000 - D8000000 (PREF.MEM)
Range 1: C8010000 - C8020000 (MEM)

_________________
Simone"Tuxedo"Monsignori, Perugia, ITALY.
   Report Go to top

Re: NetSurf development builds (now with added Javascript)
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3197
@Tuxedo

I know what has triggered this - it's the switch to OpenSSL 1.1. Memory is getting trashed somewhere, or something is unaligned which wasn't before, but it's weird that it's not happening on everything.

The only link so far is that the PA6T and E5500 (ie. X1000 and X5000) have 64-bit FPUs which gives them a different code path in OpenSSL.

   Report Go to top

Re: NetSurf development builds (now with added Javascript)
Not too shy to talk
Joined:
2006/11/28 22:14
From Perugia, ITALY
Posts: 337
@Chris

So any way to fix that easly?

_________________
Simone"Tuxedo"Monsignori, Perugia, ITALY.
   Report Go to top

Re: NetSurf development builds (now with added Javascript)
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3197
@Tuxedo

That's what I'm trying to find out
I'm running out of ideas though, nothing is making any difference.


Edited by Chris on 2017/12/10 22:43:51
   Report Go to top

Re: NetSurf development builds (now with added Javascript)
Not too shy to talk
Joined:
2006/11/28 22:14
From Perugia, ITALY
Posts: 337
So no common issue...

_________________
Simone"Tuxedo"Monsignori, Perugia, ITALY.
   Report Go to top

Re: NetSurf development builds (now with added Javascript)
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3197
@all

Should be fixed in build 4260.

   Report Go to top

Re: NetSurf development builds (now with added Javascript)
Quite a regular
Joined:
2006/11/29 8:09
From Lyon, France
Posts: 941
@Chris

I confirm it is fixed on my Sam440 (since I'm the one who contacted you regarding crashes on my Sam440 ).

Thanks !

_________________
--
AmigaONE X1000 1,8Ghz, 2GB, Sapphire Radeon HD 7700, with Amiga OS 4.1 FE
http://www.amiga-ng.org
   Report Go to top

Re: NetSurf development builds (now with added Javascript)
Not too shy to talk
Joined:
2006/12/6 19:36
Posts: 432
I can confirm 4258 did freeze the OS on AmigaOne-XE. All seem to work normally with 4266

   Report Go to top

Re: NetSurf development builds (now with added Javascript)
Not too shy to talk
Joined:
2006/12/1 3:20
From Michigan, USA
Posts: 379
@Chris

4266 is working on my A1-XEG4

Paul

_________________
Builder of Frankenthousand The monster A1000
The Young Frankenthousand A1-XE G4 2GB Sii Radeon 9250 Catweasel MKIII NEC USB2 OS 4.1FE Update 1
   Report Go to top

Re: NetSurf development builds (now with added Javascript)
Just popping in
Joined:
2017/10/28 10:03
From Netherlands
Posts: 10
@Chris

Regarding the Javascript.. its working. I tested the link as mentioned.

So i was wrong


   Report Go to top

Re: NetSurf development builds (now with added Javascript)
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3197
@Skateman

Because of a lack of dynamic layout engine, it's not always obvious that Javascript is working as a lot of JS functions normally change the page!

   Report Go to top

Re: NetSurf development builds (now with added Javascript)
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3197
There are now official AmigaOS 3.5+ development builds at http://ci.netsurf-browser.org/builds/amigaos3/

SSL is not currently working. If somebody knows what is wrong with OpenSSL please shout! (see also http://bugs.netsurf-browser.org/mantis/view.php?id=2583)

   Report Go to top


« 1 ... 20 21 22 (23)



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project