Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
56 user(s) are online (49 user(s) are browsing Forums)

Members: 0
Guests: 56

more...
Support us!
Recent OS4 Files
OS4Depot.net





AmigaOS 4.1 FE with the Radeon 9200 256MB card, only 128MB recognized
Just popping in
Joined:
3/10 13:15
From Norway
Posts: 15
Hi,

I have the Radeon 9200 with my AmigaOne G3-SE, however only 128MB of the total 256MB is recognized.
I read some place that this is due to the driver only initialising the card's memory from bank 1, ignoring the memory in bank 2. Most cards have only one bank, some (probably later ones) have two, apparently.

Is there any solution that is known for this ?

I know 256MB is probably not needed with this card, as most older 3D codes under AmigaOS (OpenGL 1.3 class card..) uses less than 128MB. . however from a curiosity viewpoint, I would like to understand the issue. I also wonder if this affects the card's memory bandwidth (for instance limiting it to 64-bit). It has a 128 bit wide memory interface to the total 256MB.

On a side note, I can never get this card running in full HD, however not issue with the 9200 SE card I have.. even same settings used.

Thanks!

   Report Go to top

Re: AmigaOS 4.1 FE with the Radeon 9200 256MB card, only 128MB recognized
Just popping in
Joined:
2008/10/18 10:25
From Auckland, New Zealand
Posts: 99
I have a Radeon 9256 with 256 MB in my A1XE G4. In earlier versions of AmigaOS 4.x, I would only see 128 MB. Then, at some point, there was an upgrade that allowed me to see all 256 MB.

I don't think I did anything other than update my version of OS4 (and now on FE). It just became available.

I don't know if it's a limitation of the G3-SE, or perhaps your card and mine are different in the way they address the extra memory.

Having said that, if I try and use more than 128 MB (usually by opening multiple screens, one of them being Odyssey), I invariably get GFX corruption.

   Report Go to top

Re: AmigaOS 4.1 FE with the Radeon 9200 256MB card, only 128MB recognized
Just can't stay away
Joined:
2006/12/1 18:01
From Copenhagen, Denmark
Posts: 1100
I think I remember something about that some 256 MB cards have the two banks with consecutive addresses, while others have them in separated address areas, and the driver could only access it all on the consecutive ones.

Or something ...

Best regards,

Niels

   Report Go to top

Re: AmigaOS 4.1 FE with the Radeon 9200 256MB card, only 128MB recognized
Just popping in
Joined:
3/10 13:15
From Norway
Posts: 15
@daveyv
Thanks, I see. I also have PCI based 9200, on that one the full 256MB is seen and useable. However I prefer the AGP one as it provides 566 MB/s rather than 266. :)

@nbache

That's interesting. Thanks.
In theory, maybe a VBIOS hex-edit mod would allow it to be consecutive. Wonder if anyone has looked into such before.

Though, it's probably easier to have the driver updated. Who is behind the Radeon.chip driver ? :)
--

In addition, I have tested with a Radeon 9100, which should be close to the 8500LE in speed. That one gives the boot screen and loads the desktop, however all window-related graphics (edges of the windows, buttons controlling the window etc) becomes distorted. Contents of windows and background / icons is fine though . Wonder why the driver was not developed to support these stronger cards.. The 9000 / 9000 Pro should work correctly with full acceleration though.


Edited by monomango on 2019/3/21 5:20:35
Edited by monomango on 2019/3/21 5:21:32
_________________
AmigaOne G3-SE : Radeon 9200 AGP 256MB, G3@667MHz, 2GB Reg 133MHz RAM, RTL8169 gigabit Ethernet, NEC USB 2.0, Sii0680/Sii3114, PS/2 keyboard and mouse, AmigaOS 4.1 FE, Linux
AmigaOne X5000 : Radeon HD7970, 16GB Reg RAM, ESI Juli@, AmigaOS 4.1 FE, Linux
   Report Go to top





[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project