Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
56 user(s) are online (39 user(s) are browsing Forums)

Members: 1
Guests: 55

nbache, more...
Support us!
Recent OS4 Files
OS4Depot.net



(1) 2 3 »


smtube! Really good!
Quite a regular
Joined:
2008/4/10 13:57
From Northern Ireland
Posts: 871
Just got Qt installed. Fantastic project, thank you alfkil!

First program I tried was smtube. A bespoke Youtube browser which is fully configurable. Allows user selectable resolution for playback and recording. Select your geography. Copy and paste Youtube urls. Easily search YouTube. A really cool program. Thanks and well done zzd10h!

Whilst I do not have any significant issues, there are two minor glitches.

1. Some videos start and run at double speed. How can I avoid this?
2. Some videos hitch, jump, drop frames and freeze. I changed playback to 360 .mp4 but it still happens. Are there any tweaks that I can make other than those set out in the readme file?

Many thanks.


Edited by ddni on 2014/1/11 20:24:33
   Report Go to top

Re: smtube! Really good!
Just popping in
Joined:
2010/10/15 6:13
Posts: 95
@ddni

Yeah I have the double time speed issue also, only just started recently never use to do it.

   Report Go to top

Re: smtube! Really good!
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1470
@ddni @fairdinkem

Never see that except when I used MUIMplayer to watch some MOV videos (therefore not with SMTube)

Do you have videos link where the problem occurs.

I think that it's not a SMTube problem but a MUIMplayer problem...


ddni : PM sent for a test

   Report Go to top

Re: smtube! Really good!
Quite a regular
Joined:
2008/4/10 13:57
From Northern Ireland
Posts: 871
Thanks.

It seems the test has resolved both of my minor niggles (only had 10 minutes testing so far).

Great stuff.

If I get a double speed video again, I will post the link here.

_________________
AmigaOne X1000.
Radeon R9 270X

http://www.tinylife.org.uk/
   Report Go to top

Re: smtube! Really good!
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1470
Nice :)
And don't forget to grab the last version on os4depot !

   Report Go to top

Re: smtube! Really good!
Quite a regular
Joined:
2013/10/5 14:07
From Italy
Posts: 616
@zzd10h

not for repeat my self ... but ... ... ... ... Bravo Guillaume! ;)

   Report Go to top

Re: smtube! Really good!
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1470
@tlosm
Thank you Luigi,
I like when you ramble like that

   Report Go to top

Re: smtube! Really good!
Just can't stay away
Joined:
2007/10/25 9:21
From Gothenburg / Sweden
Posts: 1175
I also have doublespeed problem with some videos i watch from youtube with muimplayer. Had this since beginning. Most videos works nice except some.

   Report Go to top

Re: smtube! Really good!
Just popping in
Joined:
2008/11/20 20:09
Posts: 202
Since the playback task is done with mplayer and smtube basically just retrieves the direct links and passes them to mplayer, any issue with playback is obviously caused by mplayer...

Now, this double speed issue is old and fixed since several years. It was triggered with mono audio tracks (this format was not properly handled by the ahi audio ouput). So if you don't have a recent enough version of mplayer, the easiest solution is to force the audio output to stereo, using -af format=s16be or whatever.

   Report Go to top

Re: smtube! Really good!
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1470
Thank you Fab for the explanation.

Personally, I use SDL Mplayer from MickJT and I never had this problem.

   Report Go to top

Re: smtube! Really good!
Just popping in
Joined:
2008/11/20 20:09
Posts: 202
@zzd10h

As i said, the issue was with AHI audio output. MPlayer SDL uses SDL audio output, and you probably shouldn't use it if you want any decent performance, btw.

   Report Go to top

Re: smtube! Really good!
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1470
@Fab
Yes, I understood that the problem was only with MUIMplayer, it was just to say that no problem with another MPlayer version

Performance are OK (at least for youtube videos) with the SDL version and overall it allows to resize the window on non overlay gfx cards.

   Report Go to top

Re: smtube! Really good!
Quite a regular
Joined:
2008/4/10 13:57
From Northern Ireland
Posts: 871
Hi Fab, thanks for the explanation.
Now for the obvious question, will you consider producing an updated mplayer for OS4?

_________________
AmigaOne X1000.
Radeon R9 270X

http://www.tinylife.org.uk/
   Report Go to top

Re: smtube! Really good!
Just popping in
Joined:
2007/3/25 23:56
From Los Angeles
Posts: 112
@Fab

"the easiest solution is to force the audio output to stereo, using -af format=s16be or whatever.'


Hi Fab, how are you? What do you mean by these args? where with they go in tooltypes or arguments for smplayer? thanks


   Report Go to top

Re: smtube! Really good!
Just can't stay away
Joined:
2007/10/25 9:21
From Gothenburg / Sweden
Posts: 1175
I tried a video that has doublespeed problem, it works good with sdlmplayer but plays too fast with muimplayer. I tried it like this

Work:Graphics/Video/MPlayer/MPlayer -af format=s16be video.mp4

MPlayer -af format=s16be dh2:Files/WKZ_1326331_500.mp4

Here's the shell output.

MPlayer UNKNOWN-4.4.3 (C) 2000-2010 MPlayer Team
160 audio & 349 video codecs

Playing dh2:Files/WKZ_1326331_500.mp4.
libavformat file format detected.
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (aac), -aid 0, -alang und
VIDEO: [H264] 640x360 24bpp 29.970 fps 501.1 kbps (61.2 kbyte/s)
Clip info:
major_brand: M4V
minor_version: 1
compatible_brands: isomavc1mp42
VO: [cgx_wpa] Welcome man !.
Message: Béni soit le faiseur et son nom.

Opening video filter: [screenshot]
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 32000 Hz, 1 ch, s16be, 30.3 kbit/5.91% (ratio: 3784->64000)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
AHI: Using 0x30002 AudioID.
AHI: Using 10584 bytes per chunk and 330 Kb for buffer
AO: [ahi] 32000Hz 1ch s16be (2 bytes per sample)
Starting playback...
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
[swscaler @ 0x56d29840]ALTIVEC: Color Space RGB24
[swscaler @ 0x56d29840]using unscaled yuv420p -> rgb24 special converter
VO: [cgx_wpa] 640x360 => 640x360 Planar YV12
VO: Disabling blanker
[swscaler @ 0x56d29840]ALTIVEC: Color Space RGB24

   Report Go to top

Re: smtube! Really good!
Quite a regular
Joined:
2008/4/10 13:57
From Northern Ireland
Posts: 871
Using MickJTs SDLMplayer -no altivec (thanks Mick) with SMtube.
Running two videos at same time. All seems smooth, sound is in sync. CPU use under 50%

Resized Image


video 1 http://www.youtube.com/watch?v=qWAF9PgDg2c
video 2 http://www.youtube.com/watch?v=9LUv3kbmNfg

   Report Go to top

Re: smtube! Really good!
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1470
@ddni

Why do you say "-no altivec", is it better with this switch on your x1000 ?

And for info, there is an option in the Amiga/PlayVideo.rexx to position the console window.

For example, commented in the rexx, you can put the console window in the bottom right corner at a little dimension.

   Report Go to top

Re: smtube! Really good!
Quite a regular
Joined:
2008/4/10 13:57
From Northern Ireland
Posts: 871
no, I just mention no altivec as mick told me he is planning an altivec enabled release. I wanted to avoid any possible future confusion.

_________________
AmigaOne X1000.
Radeon R9 270X

http://www.tinylife.org.uk/
   Report Go to top

Re: smtube! Really good!
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1470
@All

Hello guys,

Ricardo 'rvm' Villalda, author of SMTube have nicely included my AmigaOS4 changes to the official SMTube svn repository.

It means that now, it's possible to take the sources from the svn repository and directly compile the most recent release.

He agrees too to add a "AmigaOS4" picture in the Download page.

I have to send him a PNG logo.

Is somebody have a PNG picture (mini 32x32) of the official AmigaOS4 logo ?


It's an occasion to show that AmigaOS is not completely dead

http://forum.smplayer.info/viewtopic.php?f=4&t=7081&p=11367#p11367

http://smplayer.sourceforge.net/en/downloads

Thank you by advance for help !

   Report Go to top

Re: smtube! Really good!
Just popping in
Joined:
2006/12/6 12:39
From Finland
Posts: 146
@zzd10h

Good :)

Define official logo...

   Report Go to top


(1) 2 3 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project