Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
76 user(s) are online (58 user(s) are browsing Forums)

Members: 1
Guests: 75

Raziel, more...
Support us!
Recent OS4 Files
OS4Depot.net





making AmiCynix work on SAM460
Just popping in
Joined:
2006/12/18 1:32
From Hawaii
Posts: 221
I copied my AmiCygnix directory from my AmigaOne to SAM460ex.

I wasn't surprised to find that it wouldn't just work as is, but is there any way to tweak it so it will?

Or do I have to reinstall it in a clean directory? (I did copy over

amicygnix-base.lha 81465640 ----rw-d 19-Dec-09 15:05:00
amicygnix-tools.lha 50458750 ----rw-d 19-Dec-09 16:59:51

in case I need them.)

I'm hoping I won't have to reinstall and reconfigure everything.

   Report Go to top

Re: making AmiCynix work on SAM460
Home away from home
Joined:
2006/11/30 18:43
From Norway
Posts: 2470
Did you add a new assign? If you did try and remove it and you should get aassign request when starting up. It should work afaik.

   Report Go to top

Re: making AmiCynix work on SAM460
Home away from home
Joined:
2007/5/19 13:23
From England
Posts: 3552
There is also an EnvArc:Cygnix folder containing various prefs, including some paths.

   Report Go to top

Re: making AmiCynix work on SAM460
Not too shy to talk
Joined:
2006/12/24 12:23
Posts: 479
Quote:

kilaueabart wrote:
I copied my AmiCygnix directory from my AmigaOne to SAM460ex.

I wasn't surprised to find that it wouldn't just work as is, but is there any way to tweak it so it will?

Or do I have to reinstall it in a clean directory? (I did copy over

amicygnix-base.lha 81465640 ----rw-d 19-Dec-09 15:05:00
amicygnix-tools.lha 50458750 ----rw-d 19-Dec-09 16:59:51

in case I need them.)

I'm hoping I won't have to reinstall and reconfigure everything.

AmiCygnix should work after these steps:

* add this to your user-startup:
;BEGIN Cygnix
assign Cygnix:
execute Cygnix:S/Cygnix-Startup
;END Cygnix

* copy these libraries to LIBS:
sysvipc.library
threads.library

* Make a reset

* Copy ENVARC:Cygnix to your new system or (maybe better) execute "Cygnix:S/Utilities/Reset-Environment.bat".

* Execute "Cygnix:S/Utilities/Refresh-ALL-Caches.bat".

That's all (I hope I didn't forget anything)

   Report Go to top

Re: making AmiCynix work on SAM460
Just can't stay away
Joined:
2006/12/9 10:44
From Lyon, France
Posts: 1335
If I remember well, I tried it just copying the directory and of course selecting a new screen resolution (i.e. modeid) in the prefs program.

But I also remember that I installed it again and .. it's soooo fassst on the 460. Do you remember when the font cache was made by the installer? Now it takes a few seconds.

   Report Go to top

Re: making AmiCynix work on SAM460
Just popping in
Joined:
2006/12/18 1:32
From Hawaii
Posts: 221
Quote:

cygnusEd wrote:
Quote:

* add this to your user-startup:
;BEGIN Cygnix
assign Cygnix:
execute Cygnix:S/Cygnix-Startup
;END Cygnix

I had those. I copied my A1's User-Startup intact. (Not necessarily a good idea, but I found out how many things I have on the A1 that I don't on the SAM!)
Quote:

* copy these libraries to LIBS:
sysvipc.library
threads.library

Those I needed. Would it be safe to copy all my A1 libraries over, or are there system conflicts in them?
Quote:

* Copy ENVARC:Cygnix to your new system or (maybe better) execute "Cygnix:S/Utilities/Reset-Environment.bat".
* Execute "Cygnix:S/Utilities/Refresh-ALL-Caches.bat".
That's all (I hope I didn't forget anything)



It turns out I was wrong when I thought I had copied the whole partition over:

5.OS4.1:> Cygnix:S/Utilities/Refresh-ALL-Caches.bat
EXECUTE: Can't open "Refresh-Font-Caches.bat".

I have to go back to the A1 and see what it has that I didn't get over to the SAM.

   Report Go to top

Re: making AmiCynix work on SAM460
Just popping in
Joined:
2006/12/18 1:32
From Hawaii
Posts: 221
Quote:
kilaueabart wrote:
[quote]It turns out I was wrong when I thought I had copied the whole partition over:

5.OS4.1:> Cygnix:S/Utilities/Refresh-ALL-Caches.bat
EXECUTE: Can't open "Refresh-Font-Caches.bat".

I have to go back to the A1 and see what it has that I didn't get over to the SAM.


I jumped from there to the conclusion that I hadn't copied over something font-related, but that wouldn't explain why the command can't even open the very simple Refresh-Font-Caches.bat script:

------------------------
;
; $VER: Refresh-Font-Caches.bat 1.0 2008-05-30 Edgar Schwan
;
Echo "m*nRefreshing font caches...m"
Cygnix:CygnixPPC/bin/fc-cache --force --verbose
------------------------

I ended up just running "fc-cache" in a shell (without the --force --verbose args) and now AmiCynix comes up OK, apparently.

Sylpheed doesn't know my ISP preferences. I wonder where they are supposed to be?


   Report Go to top

Re: making AmiCynix work on SAM460
Not too shy to talk
Joined:
2006/12/24 12:23
Posts: 479
@kilaueabart

Good to hear, that it works .

The script does only work, when your current directory is "Cygnix:S/Utilities"! I suggest to run the script through it's workbench icon.

All settings of Sylpheed are stored in "Cygnix:Home/root/.sylpheed-2.0". The account settings are in "accountrc".
If this exist, please check the value of the variable "Cygnix/HOME". It must be set to "/Cygnix/Home/root".


@ Elwood

Damn - I need a SAM460! I'm green with envy

(But this is good news of course )

   Report Go to top





[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project