Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
57 user(s) are online (47 user(s) are browsing Forums)

Members: 1
Guests: 56

AmigaBlitter, more...
Support us!
Recent OS4 Files
OS4Depot.net





YT(.rexx)
Home away from home
Joined:
2007/5/19 13:23
From England
Posts: 3495
I'm replying to this post.

@m1nuto Quote:
I really like that script, that's a fantastic interface it creates. I still think I prefer ClipGrab or SMTube because they utilitze a different method to start downloads versus starting the download in Odyssey. I have issues sometimes where Odyssey freezes when there are multiple downloads started. But definitely will make use of the script, especially since there is no need for a special mplayer command, or Emotion to view the resulting downloads. ClipGrab doesn't have this have this player specific issue when it is used to download videos.

YT can be configured in a lot of different ways. Sounds like you are using the HTML page mode.

But it does not need to use Odyssey at all! I've got mine set-up to (optionally) ask some questions in a Shell window, and then play the video directly in MPlayer. The downloading is done by MPlayer.

_________________
Author of the PortablE programming language.
I love using Amiga OS4.1
It is pitch black. You are likely to be eaten by a grue...
   Report Go to top

Re: YT(.rexx)
Not too shy to talk
Joined:
2006/11/27 22:28
From Germany
Posts: 287
unfortunately it does not work with emotion regarding youtube streams.
emotion only says that the "media format is not supported" or smth.
the very same link/stream does work with mplayer, though.
i'd prefer emotion.

regards...
michael

_________________
Michael Merkel
(Michael.Merkel@gmx.net Home)
Member of Amiga-Freunde Pfalz, OS4 Welt
   Report Go to top

Re: YT(.rexx)
Just popping in
Joined:
9/27 3:41
From USA
Posts: 61
@MichaelMerkel

Quote:
unfortunately it does not work with emotion regarding youtube streams.
emotion only says that the "media format is not supported" or smth.
the very same link/stream does work with mplayer, though.
i'd prefer emotion.



I can confirm, the resulting downloads from using YT.rexx work just fine in Emotion player. In regards to playing the stream directly from the hyperlinks via Emotion, I don't think that works due to the link utilizing some redirect to the actual data for the video. I'm guessing Emotion, like the download executable, doesn't understand this kind of reference.


But if your aim is to download the video, YT.rexx works great!

Resized Image

_________________
-A1200 w/ Blizzard 1230 - 128MB FastRam
-X5000 1TB SSD HD - 16GB RAM
   Report Go to top

Re: YT(.rexx)
Home away from home
Joined:
2007/5/19 13:23
From England
Posts: 3495
@m1nuto
Which OS4 Theme are you using in that screenshot?

_________________
Author of the PortablE programming language.
I love using Amiga OS4.1
It is pitch black. You are likely to be eaten by a grue...
   Report Go to top

Re: YT(.rexx)
Quite a regular
Joined:
2009/4/28 3:57
From Adelaide, Australia
Posts: 837
Quote:
In regards to playing the stream directly from the hyperlinks via Emotion, I don't think that works due to the link utilizing some redirect to the actual data for the video.


I don't know if Emotion supports HTTPS now, but if it still doesn't, then that's the problem. MPlayer is able to stream via STDIN, so I use that method in YT.rexx, or there's a setting to use HTTPS links in MPlayer directly if you have a build with SSL support.

If Emotion does support HTTPS links now, then it's just a matter of using NoPipe as an argument, or setting UsePipe = 0.

   Report Go to top

Re: YT(.rexx)
Not too shy to talk
Joined:
2006/11/27 22:28
From Germany
Posts: 287
@MickJT

Quote:

I don't know if Emotion supports HTTPS now, but if it still doesn't, then that's the problem. MPlayer is able to stream via STDIN, so I use that method in YT.rexx, or there's a setting to use HTTPS links in MPlayer directly if you have a build with SSL support.

If Emotion does support HTTPS links now, then it's just a matter of using NoPipe as an argument, or setting UsePipe = 0.


i guess missing https support may be the problem.
so we need to tease entwicklerx

regards...
michael

_________________
Michael Merkel
(Michael.Merkel@gmx.net Home)
Member of Amiga-Freunde Pfalz, OS4 Welt
   Report Go to top

Re: YT(.rexx)
Just popping in
Joined:
2006/12/2 1:41
From VA, USA
Posts: 193
Hey guys,

There's little reason to suffer the unreliability and
crashes of Oddity....err, Odyssey.

While it may not be *pretty*, YouTube in generally works
in IBrowse and the HTML output of YT.rexx was specifically
written to work flawlessly in IBrowse.

No crashes, no fuss, no muss.

Furthermore, you can set up FAB Menus in IBrowse to
asyncronously stream the YT.rexx links to MPlayer with
just a right-click.

IIRC, the information for all this is in the YT.rexx
AmigaGuide file.

With a low enough resolution, I've been streaming YT videos
("autoplay") on my little ole SAM440mini.

Thanks,

PJS


   Report Go to top

Re: YT(.rexx)
Home away from home
Joined:
2007/5/19 13:23
From England
Posts: 3495
@pjs
No significant instability here with Odyssey, although I do have JavaScript disabled by default (only enabled for sites that need it). (It may also help that I have GBs of RAM, so Odyssey isn't likely to run out of RAM - a fairly sure way of crashing it.)

_________________
Author of the PortablE programming language.
I love using Amiga OS4.1
It is pitch black. You are likely to be eaten by a grue...
   Report Go to top

Re: YT(.rexx)
Quite a regular
Joined:
2007/2/27 10:47
From Gravity well
Posts: 575
@pjs

SSL3_GET_RECORD:wrong version number

Same as with so many old mobile devices, IBrowse doesn't want to SSL anymore. But I gather in this case there's a way?

edit: Since the answer may be off-site, I put it here: setenv AMISSL/SSL_CLIENT_VERSION tls1


Edited by Thematic on 2017/10/18 17:45:43
   Report Go to top





[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project