Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
46 user(s) are online (39 user(s) are browsing Forums)

Members: 0
Guests: 46

more...
Support us!
Recent OS4 Files
OS4Depot.net



« 1 2 (3) 4 5 6 ... 14 »


Re: Enhancer Bug thread
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3181
@kas1e
Wooah, give me chance, I've only just seen this.

@amigakit
I've PM'd you as it's easier from here.

   Report Go to top

Re: Enhancer Bug thread
Just can't stay away
Joined:
2006/12/4 23:15
Posts: 1909
@Raziel

1. It's not supposed to save. Read the doc for alist of actual saveable settings.

2. The word wrap as you type behaviour is derrived from the texteditor.gadget and not implemented at application level. IT's very simplistic and does not attempt to do word boundaries or rearrange and subsequent text.

_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top

Re: Enhancer Bug thread
Just can't stay away
Joined:
2008/1/6 17:56
From Pennsylvania, USA
Posts: 1249
Late yesterday, I opened the Multiviewer about window and got a crash. I thought the workaround for the Infowindow problem was to add an image in 'GUI Preferences/Gadgets/General/Background Texture'. I have a pattern image set in the 'Background Texture' but still get the crash. Am I confused about this or has something else gone wrong with my system?

_________________
Amiga X1000 with 2GB memory & OS 4.1FE + Radeon HD 5450

   Report Go to top

Re: Enhancer Bug thread
Quite a regular
Joined:
2009/5/1 17:57
From Czech Republic
Posts: 941
@xenic

Is it a crash, or a freeze? Do other Enhancer programs trigger the problem when you open their About window?

_________________
Smoke me a kipper, I'll be back for breakfast!
SAM440ep-flex @ 667MHz / 1GB RAM / Radeon 9250 / AmigaOS 4.1 Final Edition
   Report Go to top

Re: Enhancer Bug thread
Home away from home
Joined:
2006/11/26 21:45
From A haunted Castle somewhere in the Bavarian Mountains
Posts: 2902
@trixie

Thank you, sir

_________________
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
   Report Go to top

Re: Enhancer Bug thread
Home away from home
Joined:
2006/11/26 21:45
From A haunted Castle somewhere in the Bavarian Mountains
Posts: 2902
@broadblues

1. Then please take it as a festure request to make word wrapping default, or at least let the user decide if it's enabled by default.

2. Ok, so this texteditor.gadget is A-Eon aswell?
If so, could those features for word wrapping be implemented?

Or is 1. disabled by default because of 2. isn't very mature?

_________________
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
   Report Go to top

Re: Enhancer Bug thread
Just can't stay away
Joined:
2006/12/4 23:15
Posts: 1909
@Raziel

Quote:

@broadblues

1. Then please take it as a festure request to make word wrapping default, or at least let the user decide if it's enabled by default.


Noted, but not going to do it till the gadget works better.

Quote:

2. Ok, so this texteditor.gadget is A-Eon aswell?
If so, could those features for word wrapping be implemented?


It's this system gadget, the same on as used by NotePad, MultiEdit is essentially NotePad with all the bells and whistles added. I don't think you can access the word wrap feature from NotePad (this is distinct from the line wrapping in the display, which keeps the lines intact but wraps them in the view) so I guess it was never stress tested. BZ has been raised IIRC.

Quote:

Or is 1. disabled by default because of 2. isn't very mature?


Sort of.

_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top

Re: Enhancer Bug thread
Just can't stay away
Joined:
2008/1/6 17:56
From Pennsylvania, USA
Posts: 1249
@trixie
Quote:
Is it a crash, or a freeze? Do other Enhancer programs trigger the problem when you open their About window?

It's actually a system freeze (with slight delay). If I'm quick enough, I can perform a warm reboot after the blank window opens but before the freeze takes hold. After the warm reboot I can recover debug output from memory that includes Grim Reaper output. The stack trace always ends in window.class. I don't think DiskImageGUI is using Infowindow but it has the same system freeze and the stack trace ends in window.class.

The other Enhancer programs trigger the same freeze when their About windows are open. I could have sworn I fixed the problem by adding a pattern image in 'GUI Preferences/Gadgets/General/Background Texture'. Is adding an image in 'Background Texture' supposed to work around the problem or am I getting things confused?

_________________
Amiga X1000 with 2GB memory & OS 4.1FE + Radeon HD 5450

   Report Go to top

Re: Enhancer Bug thread
Just can't stay away
Joined:
2006/12/4 23:15
Posts: 1909
@xenic

That *is* suposed to be the work arround yes, check your UI prefs maybe you reset them without realising?


_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top

Re: Enhancer Bug thread
Just popping in
Joined:
2008/10/18 10:25
From Auckland, New Zealand
Posts: 48
Can Multiviewer please support the PageUp/Down keys? Thanks.

   Report Go to top

Re: Enhancer Bug thread
Just can't stay away
Joined:
2006/12/4 23:15
Posts: 1909
@daveyw

IT uses them to page through the filelist.

_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top

Re: Enhancer Bug thread
Just can't stay away
Joined:
2008/1/6 17:56
From Pennsylvania, USA
Posts: 1249
@broadblues
Quote:
That *is* suposed to be the work arround yes, check your UI prefs maybe you reset them without realising?

I checked and my setting which is:
Sys:Prefs/Presets/Default/Common/Patterns/smallerw.png

It's the same setting that is there when I booted from the OS4.1FE CD. I cold booted with the OS4.1FE CD and because there is no infowindow.class on that CD, I tested DiskimageGUI (which has the same problem as infowindow.class) and it worked; no freeze and normal window.

Apparently there is more to the problem than the GUI prefs gadget setting. I guess my next step will be to reinstall OS4.1FE on my alternate boot partition and see what happens when I start reinstalling OS4.1FEu1 and Enhancer stuff.

_________________
Amiga X1000 with 2GB memory & OS 4.1FE + Radeon HD 5450

   Report Go to top

Re: Enhancer Bug thread
Just can't stay away
Joined:
2006/12/4 23:15
Posts: 1909
@xenic

The main prefs only affects thyeWorkbench and SA_LikeWorkbench screens.

You need to set it up for the default screen type in Screen prefs to IIRC.

[edit]
Check that <<default>> is set to Like WorkBench on the GUI tab, by default it defaults to errm Use defaults (which looks abit 3.1ish)


_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top

Re: Enhancer Bug thread
Just can't stay away
Joined:
2008/1/6 17:56
From Pennsylvania, USA
Posts: 1249
@broadblues
Quote:
You need to set it up for the default screen type in Screen prefs to IIRC.
edit
Check that <<default>> is set to Like WorkBench on the GUI tab, by default it defaults to errm Use defaults (which looks abit 3.1ish)


Did that but nothing changed. I did install a backup of my original OS4.1FE install on an alternate boot partition. I added 'shared.image' and 'infowindow.class' so I could test the Multiviewer 'About' window on the FE partition. I changed the priority of the FE partition so that it's the primary boot partition. After a hard reboot, I tested Multiviewer with a Gadget background image and without a Gadget background image. It now works as it previously did; with the background image no problem & without the background image a freeze.

Tomorrow I need to start reinstalling update1 & Enhancer stuff to see if I can determine what else is affecting the window.class freeze and fix my normal boot partition.

_________________
Amiga X1000 with 2GB memory & OS 4.1FE + Radeon HD 5450

   Report Go to top

Re: Enhancer Bug thread
Home away from home
Joined:
2006/11/26 21:45
From A haunted Castle somewhere in the Bavarian Mountains
Posts: 2902
@broadblues

Thank you

_________________
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
   Report Go to top

Re: Enhancer Bug thread
Quite a regular
Joined:
2009/5/1 17:57
From Czech Republic
Posts: 941
@xenic

Quote:
the window.class freeze

The funny thing is that this bug has been fixed in the OS4 beta for almost half a year now. But now that OS fixes are not delivered via AmiUpdate, we'll have to wait for a new update pack (which is scheduled for when-it's-done).

_________________
Smoke me a kipper, I'll be back for breakfast!
SAM440ep-flex @ 667MHz / 1GB RAM / Radeon 9250 / AmigaOS 4.1 Final Edition
   Report Go to top

Re: Enhancer Bug thread
Just can't stay away
Joined:
2008/1/6 17:56
From Pennsylvania, USA
Posts: 1249
@trixie
Quote:
The funny thing is that this bug has been fixed in the OS4 beta for almost half a year now. But now that OS fixes are not delivered via AmiUpdate, we'll have to wait for a new update pack (which is scheduled for when-it's-done).

Since someone seems to think that updates must be delivered at a computer show or for Christmas, I think we'll be waiting at least another 4-7 months (suppressing long rant)

As I pointed out to Andy, booting from an old FE partition eliminated my window.class related freeze. Since that post I've narrowed down the problem to something in my DEVS: directory; probably my datatypes. I have a complicated System partition with lots of "assign added" directories for 3rd party software so it will take me another day or two to isolate the exact cause of my freeze.

_________________
Amiga X1000 with 2GB memory & OS 4.1FE + Radeon HD 5450

   Report Go to top

Re: Enhancer Bug thread
Just can't stay away
Joined:
2008/1/6 17:56
From Pennsylvania, USA
Posts: 1249
@all
For anyone who might be interrested, I solved my additional freeze problem. I had to remove my WarpPNG datatype. The WarpPNG datatype works fine for image viewers like Multiview, Multiviewer etc. but causes freezes with some programs (DiskImageGUI) or Infowindow.class that crash in window.class. Until a fixed window.class is released I won't know if the real problem is in window.class or the WarpPNG datatype.

_________________
Amiga X1000 with 2GB memory & OS 4.1FE + Radeon HD 5450

   Report Go to top

Re: Enhancer Bug thread
Home away from home
Joined:
2006/11/26 21:45
From A haunted Castle somewhere in the Bavarian Mountains
Posts: 2902
@broadblues

CANDI (Full Version) 1.3 (23.11.2015)

There is a reproducable crash which i already reported to the coders (but i got no feedback, so it might as well be in the bug list already).

I'll report it here so it won't be forgotten.

Steps to reproduce:
1) Start CANDI (i have "Default Light v1.7 running on a custom background)
2) Insert an USB stick
3) Right-click on it's icon to bring up information
4) Choose any disk.icon and move it to the USB icon in Information
5) Save

It will reproducably crash *every* time i do this.
Even if i give the very same disk icon that is already installed.
It looks as if there is a problem with updating the screen resp. the CANDI animation after the icon has been saved and the USB icon is updated/redrawn on screen.

Why it only happens with USB devices i don't know, maybe CANDI falls over because the save and redraw/update is slower as with HDD/RAM devices, because those don't trigger the bug.

Crash log for task "Tools:Utilities/CANDI/data/DefaultLight"
Generated by GrimReaper 53.19
Crash occured in module DefaultLight at address 0x7F766AD0
Type of crash
DSI (Data Storage Interruptexception
Alert number
0x80000003

Register dump
:
GPR (General Purpose Registers):
   
07F766AC4 4FC59AE0 ABADCAFE 00000001 BEEFDEAD 00000000 00000001 00000000 
   8
00000000 0000000B 00000000 00000000 55935535 506B3260 80009065 80009047 
  16
80009059 7FFF6FA2 506B0000 506B0000 506B0000 506B0000 6117D808 506B0000 
  24
506AB528 5FEE63E0 4FC41370 6FEE9C4C 5CAC74C0 4888CC38 4FC41350 5FEE8BC0 


FPR 
(Floating Point RegistersNaN Not a Number):
   
0:              nan          1.33333              0.5     1.10452e-302 
   4
:     2.36287e-306     1.60709e-301     1.72375e-301     1.66542e-301 
   8
:     1.07916e-301       4.5036e+15             1440       4.5036e+15 
  12
:              256       4.5036e+15                0                0 
  16
:                0                0                0                0 
  20
:                0                0                0                0 
  24
:                0                0                0             -0.5 
  28
:       4.5036e+15            65536                1                5 

FPSCR 
(Floating Point Status and Control Register): 0x82004000


SPRs 
(Special Purpose Registers):
           
Machine State (msr) : 0x0200B030
                Condition 
(cr) : 0x60070CDC
      Instruction Pointer 
(ip) : 0x7F766AD0
       Xtended Exception 
(xer) : 0x5C65C018
                   Count 
(ctr) : 0x6FF364D0
                     Link 
(lr) : 0x7FB2E920
            DSI Status 
(dsisr) : 0x5C65BDD0
            Data Address 
(dar) : 0x021E4828



680x0 emulated registers
:
DATA96D73400 00000000 00000000 00000000 00000000 00000000 00000000 00000000 
ADDR
6FFB8000 96D73400 00000000 00000000 00000000 00000000 00000000 4FC59650 
FPU0
:                0                0                0                0 
FPU4
:                0                0                0                0 



Symbol info
:
Instruction pointer 0x7F766AD0 belongs to module "DefaultLight" (HUNK/Kickstart)

Stack trace:
    
module Tools:Utilities/CANDI/data/DefaultLight at 0x7F766AD0 (section 5 0x7AAC)
    
module Tools:Utilities/CANDI/data/DefaultLight at 0x7F766AC4 (section 5 0x7AA0)
    
module Tools:Utilities/CANDI/data/DefaultLight at 0x7F75FDFC (section 5 0xDD8)
    
native kernel module newlib.library.kmod+0x000020a4
    native kernel module newlib
.library.kmod+0x00002d0c
    native kernel module newlib
.library.kmod+0x00002ee8
    Tools
:Utilities/CANDI/data/DefaultLight:_start()+0x170 (section 1 0x16C)
    
native kernel module dos.library.kmod+0x000255c8
    native kernel module kernel
.debug+0x0006e9c0
    native kernel module kernel
.debug+0x0006ea08

PPC disassembly
:
 
7f766ac82f840000   cmpwi             cr7,r4,0
 7f766acc
419e05f8   beq-              cr7,0x7F7670C4
*7f766ad083c40044   lwz               r30,68(r4)
 
7f766ad42f9e0000   cmpwi             cr7,r30,0
 7f766ad8
419e0558   beq-              cr7,0x7F767030

System information
:

CPU 
 Model
P.ASemi PWRficient PA6T-1682M VB1 
 CPU speed
1800 MHz 
 FSB speed
900 MHz 
 Extensions
altivec 

Machine 
 Machine name
AmigaOne X1000 
 Memory
2097152 KB 
 Extensions
bus.pci bus.pcie


P.S: Is there a CANDI animation editor planned?
So people can create their own stuff and share?

I dream of a CANDI animation just like the DefaultLight but with dandelion seeds...rotating dandelion seeds...

P.P.S: There is also a typo in the CANDI animation list.
The Fireworks animation has a description that says
Quote:
hayppy new year
...probably because of too much bubble water.

_________________
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
   Report Go to top

Re: Enhancer Bug thread
Not too shy to talk
Joined:
2007/2/6 13:57
From Donostia (SPAIN)
Posts: 366
@Raziel
about
...
P.P.S: There is also a typo in the CANDI animation list.
The Fireworks animation has a description that says
Quote:
hayppy new year
...

Try to edit Fireworks icon and fix comment.

   Report Go to top


« 1 2 (3) 4 5 6 ... 14 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project