Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
50 user(s) are online (40 user(s) are browsing Forums)

Members: 0
Guests: 50

more...
Support us!
Recent OS4 Files
OS4Depot.net





Amissl v4.0
Quite a regular
Joined:
2009/2/9 19:32
From Brussels Belgium
Posts: 986
Yam latest dev is feclaiming amissl v4.0
Where can i get it?

Found it here
https://github.com/jens-maus/amissl/re ... wnload/4.0/AmiSSL-4.0.lha

   Report Go to top

Re: Amissl v4.0
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 4112

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: Amissl v4.0
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1430
Hi,
trying to recompile a project with latest AmiSSL (installation done manually in my SDK: because not doing by installer)

/SDK/local/newlib/lib/libamisslauto.a(autoinit_amissl_main.o): In function `__init_amissl_main':
autoinit_amissl_main.c:(.text+0x20e): undefined reference to `errno'
autoinit_amissl_main.c:(.text+0x21e): undefined reference to `errno'

including errno.h in my code doesn't solved the problem.

Is somebody encoutered this problem ?

Thanks

edit : reverted to libamisslauto.a from 2005 in my SDK:local/newlib/lib make linking works again.


   Report Go to top

Re: Amissl v4.0
Home away from home
Joined:
2006/11/26 21:45
From A haunted Castle somewhere in the Bavarian Mountains
Posts: 2799
@zzd10h

Please add it to the AmiSSL issue tracker

_________________
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
   Report Go to top

Re: Amissl v4.0
Just popping in
Joined:
2006/12/23 18:30
From UK
Posts: 63
@zzd10h

Yes, please add to the issue tracker. Jens went ahead and released AmiSSL before I had really finished writing script that builds the release archives. The included libamisslauto.a is for apps compiled to use clib2, and not newlib (the old SDK contained two versions). I did raise my concern, but was also unsure how many developers actually used it.

Anyway, as you've found, the quick fix is to use the one from the old SDK - nothing substantial, if anything, has changed in that code. Hopefully, we can get this fixed for the next release.

edit: I've just now pushed in changes to github that will resolve this for the next release.


Edited by Futaura on 2017/2/11 16:11:45
   Report Go to top

Re: Amissl v4.0
Just can't stay away
Joined:
2008/1/6 17:56
From Pennsylvania, USA
Posts: 1111
The OS4 AmiSSL V4 installer puts the docs in SYS:Documentation but the AmiSSL docs (as installed by OS4.4FE) are in SYS:Documentation/AmiSSL. A user ends up with 2 sets of AmiSSL documentation which could result in some user confusion. I just reported this at the AmiSSL repository but current users might want to place the AmiSSL docs in the correct location.

_________________
Amiga X1000 with 2GB memory & OS 4.1FE + Radeon HD 5450

   Report Go to top

Re: Amissl v4.0
Home away from home
Joined:
2006/11/26 21:45
From A haunted Castle somewhere in the Bavarian Mountains
Posts: 2799
@xenic

Good catch, thank you

_________________
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
   Report Go to top

Re: Amissl v4.0
Just popping in
Joined:
2009/2/8 14:30
From Cologne * Germany
Posts: 90
@Raziel

Not sure if this is the right place for this, as this thread obviously is for the OS4 version of AmiSSL 4.0.

Regarding the m68k version of AmiSSL 4.0, there was a news item at amiga-news.de on Feb 8th. At the end of this news item there was an 'editor's note':

editor's note: Those who are really still occasionally using IBrowse to surf the web should enable TLS to improve IBrowse's compatibility with encrypted websites significantly - even without AmiSSL-4-support.

Clicking on the "enable TLS"-link led me to an old news item of Feb 2016, where the original message of the IBrowse-development-team with an instruction on how to enable TLS in IBrowse v2.4 was linked.

Unfortunately I missed the news last year - and so I have not tested it up to now (And yes, I'm one of those infamous users "who are really still occasionally using IBrowse to surf the web").

Maybe this is now covered in AmiSSL 4.0 - but just in case it is not, I'd like to share this info with you on how to make IBrowse nevertheless access "https -sites"...

_________________
Ciao,
Dandy
-----------------------------------------------------------
If someone enjoys marching to military music, then I already despise him.
He got his brain accidently - the bone marrow in his back would have been sufficient for him!
(...
   Report Go to top





[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project