Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
58 user(s) are online (49 user(s) are browsing Forums)

Members: 0
Guests: 58

more...
Support us!
Recent OS4 Files
OS4Depot.net



« 1 (2) 3 4 5 »


Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 5389
@eliyahu
Quote:

hoo-ray! that would be outstanding


:) Yes, almost banana :) (its not that easy as one may think, there for sure will be some problems, and that can in end lead "we can't just use compositetags as we hope" ). Those ones who write me in last years, also was in hope it will be "just blalal", and in end nothing.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3140
@LiveForIt

Just to say some reported bugs related to the afxgroup version were posted here:

https://code.google.com/p/mplayer-amigaos/issues/list

At the time we was in hope in Varthall, atleast for fixing some of that famous issues related to the streaming videos, but then he give up quickly and no one take the project..

For sure would be great if you can join the project, even if at some point some of us start using the MUI version i don't see any reason to drop this old but working version

   Report Go to top

Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2734
@kas1e

Quote:
(its not that easy as one may think, there for sure will be some problems, and that can in end lead "we can't just use compositetags as we hope" ). Those ones who write me in last years, also was in hope it will be "just blalal", and in end nothing.


Just give me a few sec... while I'm downloading this thing...

any dependency I going to need to build it,
do I need to confiure it before typing make, what arguments do you use when you type configure?

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2734
@samo79

Well I'm not shore I'm going to commit my self fully, just poping in to do a few small adjustments.

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2734
@samo79

The compiler thinks I have a AMD CPU (AMD3DNOW)... I have a PaSemi

problems whit auto-detecting, it says bad things about femms and emms opcodes.


EDIT: I think I have fixed, it by doing:

Assign proc: ram:
echo powerpc > proc:cpuinfo

EDIT:

Nope did not solve it need to manually edit config.mak file


Edited by LiveForIt on 2014/3/30 17:48:40
Edited by LiveForIt on 2014/3/30 17:50:27
Edited by LiveForIt on 2014/3/30 18:16:42
_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2734
@kas1e

The CPU detected code in configure is totally crap under AmigaOS4.
The config.h and config.mak file says I have All CPU's in the world.

After som expermination I found at that need to delete the CPU models that I did not have in config.mak file, and set the CPU models in config.h to 0, to make it compile.

Plus there is some thing wrong in cpudetect.c

#include “protos/exec.h”

was put inside #if ARCH_X86, this should not be, don't understand how you managed to compile whit bugs like that.

EDIT:
I guess your using a cross compiler, most be way.

EDIT:
Disabled MPNG, some thing odd about that.

EDIT:
Configure did not find altivec.h enabled manually in config.h

EDIT:
needed to add #undef __USE_INLINE__ in ppc/cpu.h.
looks like we are mixing stuff here.

EDIT:
MPNG problem is because I'm using a newer version of LibPNG.
now "png -> xyz" should be "png_get_xyz(png)" or png_set_xyz(png)


Edited by LiveForIt on 2014/3/30 20:54:33
Edited by LiveForIt on 2014/3/30 22:14:14
Edited by LiveForIt on 2014/3/30 22:34:56
Edited by LiveForIt on 2014/3/31 11:15:09
_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3140
@LiveForIt

Quote:
Well I'm not shore I'm going to commit my self fully, just poping in to do a few small adjustments.


Ok, in any case thank you to give it a glance
Ah latest r22 includes also an updated file note, maybe you've already seen...

https://mplayer-amigaos.googlecode.com ... /r22/trunk/notes_amigaos4

   Report Go to top

Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2734
@samo79

Thanks, I think this is useful information, no normally I ignore any readme or install guides

looks like every thing is compiled now, but it did not link.

Can you copy & past two/tree lines for me from config.mak

EXTRALIBS = *
EXTRALIBS_MPLAYER = *
EXTRALIBS_MENCODER = *


Edited by LiveForIt on 2014/3/31 5:09:59
Edited by LiveForIt on 2014/3/31 5:10:46
Edited by LiveForIt on 2014/3/31 5:12:19
_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 5389
@liveforit
I build any more or less big stuff on crosscompiler , its always quite easy and problem less. But mplayer for sure can be compiled on os4 itself too, as i do it before (not with version on code-google, but with version from fab at least).

Anyway, as you wrote before you already have your own custom build based on afxgroup one, imho use that one for making radeonhd driver if it already builds for you, why you worry about build any other version ? Any mplayer version you have which already builds and links are ok for writng radeonhd driver for.

If you now will split yourself on different fixes not related to writing radeonhd driver for mplayer, you will quickly burnout.

As for deps on linking : its all usuall linking libs. You just search for unresolved functions in link-error-output in all your SDK, and include those .a where it found step by step.

For fab's mplayer my linking lines (on cross-compiler, but that not make differences) looks like this:

Quote:

EXTRALIBS = -static -Wl,-z,noexecstack -L/usr/lib -L/usr/local/lib -ljpeg -lfreetype -liconv -lz -lfontconfig_with_callback -lexpat -lfreetype -lpng12 -lz -llzo2 -lmad -ltheora -lvorbis-1.2.3 -lvorbisenc-1.2.3 -logg-1.2.0 -ldca -lrtmp -lbz2 -lssl -lpthread -lglob -lcrypto -laos4deps -lauto -lc -lm -ldebug
EXTRALIBS_MPLAYER = -static -lc -lm -lfaac -la52 -lx264 -lxvidcore -lvpx -lmp3lame -lpthread -Wl,--cref,-Map,mplayer.map


As for EXTRALIBS_MENCODER , just skip it, you no need mencoder at all for writing radeonhd driver, its different binary, different problems, and if you still will have motivation lately can deal with. You can skip it without problems, as compiling process will firstly build mplayer binary, and only then will try to build mencoder (which is does not matter now).

As for altivec and non-altivec, also skip for first test any worry about altivec, and just build genertic version, as if you will again split yourself on all that non-related to radeonhd driver crap, you will again burnout and nothing will come up from.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 5389
@All

Anyone who have problems with detection of non-having overlay and automatic fallback to cgx_wpa in muimplayer want to do remote tests with me ? I.e. i will build some version for test, send, you test it, report back, and so on.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Just can't stay away
Joined:
2009/2/9 19:32
From Brussels Belgium
Posts: 1121
@all
I was provided with MickJT's SDL-Mplayer and it works like a charm on my SAM460ex
I don't really understand the discussions and neither why SDL-Mplayer is not easily available.

   Report Go to top

Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2734
@JosDuchIt

You can't resize the window on the SDL version, in addition to Picasso 96 overlay video driver users less CPU.

I do not yet know how composition is going to preform compared to Picasso 96 version yet, but I'm guessing some where in between.

Overlay's use less bandwidth, because it uses a different way to present colors then the standard RGB mode, basically its a 16 bit mode that looks almost as prefect as 32 bit mode.

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Just popping in
Joined:
2007/1/1 12:01
From Latina, Italy
Posts: 208
@kas1e, LiveForIt

did you read this thread about how to speed up a video player specially on Sam boards which can use DMA with certain graphic functions as WritePixelArray()/BlitBitMap()

http://www.amiga.org/forums/showpost.php?p=760904&postcount=74

it's very important to use these functions than others because they use DMA and can speed up above 2x and in some case 6x without using a CPU !! The video player should use them as much as can

_________________
Sam 460EX, 2Gb Ram, Radeon R7 250, AmigaOS4.1 FE
A4000 PPC604@233, Mediator
A1200 PPC603@160, Mediator
uA1 G3@800, 512 Mb [sold]
   Report Go to top

Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1494
@LiveForIt
"You can't resize the window on the SDL version"

Yes, you can, at least with MickJT version.

It's specifically why it's better than MUIMplayer on non-overlay system.

It's MUI-Mplayer that doesn't allow to resize the window, therefore YouTube (SMTube) videos are very hard to see on non overlay system.

   Report Go to top

Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2734
@sofistisoftware

Yes I remember reading that.

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Just popping in
Joined:
2007/1/1 12:01
From Latina, Italy
Posts: 208
@all

with latest version 1.0 of RadeonHD driver there's a big improvement (at least on my Sam460 with Saphire 4670) as i wrote in Amigaworld thread now i can watch youtube videos in 400x240 with 98% cpu busy and audio/video syncronized, i use Fab's internal html5 video player and his script youtube conversion, for my testing it has been the fastest

_________________
Sam 460EX, 2Gb Ram, Radeon R7 250, AmigaOS4.1 FE
A4000 PPC604@233, Mediator
A1200 PPC603@160, Mediator
uA1 G3@800, 512 Mb [sold]
   Report Go to top

Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2734
@kas1e

What version of libvorbis do you use?
they just do not want to link, I think some thing is missing.

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Just popping in
Joined:
2007/3/19 13:44
From Up Rough
Posts: 170
@LiveForIt

Hi,

as Samo already pointed out, in the notes_amigaos4 file there are some useful tips on how to compile it, although it is not complete. Check the "Linking errors fixes" to see if there's anything useful there for your linking problems.

I'll happily submit any contribution to the MPlayer SVN, feel free to PM me if you have anything you would like to add there.

BTW how fast does it compile on your X1000? A complete compile takes 1hr on my 1GHz A1, while it only takes 10 mins or so on my 2Ghz laptop under Linux, although I have always been unable to compile an Altivec version there.

Varthall

   Report Go to top

Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3140
@LiveForIt

Quote:
Can you copy & past two/tree lines for me from config.mak


It's all on the notes_amigaos4 file i link you above, but you can also ask Varthall instead

   Report Go to top

Re: (MUI-)MPlayer & Mplayer-GUI on SAM460ex
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2734
@Varthall

Yes thats is what is taking time, I'm not shore how long it takes, but at least 30-45min. For every clean & make.
(CPU load around 75%)

I have made two scripts for this, as “make clean” deletes more then it should, and having to enter “sh” to do make all, its a bit boring, and conflicts whit my text editor.

I have one or two fixes but they are most already described in the guide by Samo.

Some of the things in the guide did not work so well, don't know way, think some thing has changed after the document was written, and some things are not needed anymore.

I have Altivec enabled, it works here, once is sorted out CPU settings and stuff, sorry do not remember if there was anything else I did there.

Once I have every thing working I want need to do a Make clean again (hopefully), so the time it takes now, is not a issue, when I'm starting working on it.


Edited by LiveForIt on 2014/4/1 0:42:04
Edited by LiveForIt on 2014/4/1 0:44:44
Edited by LiveForIt on 2014/4/1 0:46:04
_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top


« 1 (2) 3 4 5 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project