Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
81 user(s) are online (59 user(s) are browsing Forums)

Members: 0
Guests: 81

more...
Support us!
Recent OS4 Files
OS4Depot.net



« 1 2 3 (4)


Re: CMake progress
Just can't stay away
Joined:
2009/10/7 0:11
From Copenhagen
Posts: 1186
@Capehill

Oops... Seems like I have updated the Modules/Platform/AmigaOS.cmake file without copying it to the release directory... Sorry! I will make a new release shortly.

EDIT: Ignore the post above, the version in the release is correct.


Edited by alfkil on 2017/3/14 20:14:10
   Report Go to top

Re: CMake progress
Just can't stay away
Joined:
2009/10/7 0:11
From Copenhagen
Posts: 1186
@Capehill

You are absolutely correct, the test builds all leave out -use-dynld. I will have to find a fitting place to insert it. Thanks for the report!

   Report Go to top

Re: CMake progress
Quite a regular
Joined:
2006/11/22 17:57
From Italy, Rome
Posts: 536
@alfkil

Hi Alfkill,

unfortunately cmake still crash for me.

I will send you the crash log as soon as possible.


P.S.

Thank you for your great work, btw.

_________________
Retired
   Report Go to top

Re: CMake progress
Home away from home
Joined:
2006/11/26 21:45
From A haunted Castle somewhere in the Bavarian Mountains
Posts: 2881
@broadblues

Thank you, with your hints i fixed the path problem and (hopefully) all further compiling issues

_________________
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
   Report Go to top

Re: CMake progress
Just can't stay away
Joined:
2009/10/7 0:11
From Copenhagen
Posts: 1186
@AmigaBlitter

Could you send also the output from the console? Thanks!

   Report Go to top

Re: CMake progress
Quite a regular
Joined:
2006/11/22 17:57
From Italy, Rome
Posts: 536
@alfkil

Setting the stack to 128000 avoid the crash.

However, when i try to compile something, i get:

"cmake ..
CMake Error: CMake was unable to find a build program corresponding to "Unix Makefiles". CMAKE_MAKE_PROGRAM is not set. You probably need to select a different build tool.
CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage
CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
-- Configuring incomplete, errors occurred!
"

_________________
Retired
   Report Go to top

Re: CMake progress
Quite a regular
Joined:
2007/2/27 10:47
From Gravity well
Posts: 574
@AmigaBlitter

I don't remember this stuff, but I have an old memo that says to do

Quote:

cmake ..
cmake -i ..
cmake ..


-i probably means interactive, so you can then try to fix what is wrong.

Maybe it doesn't work for this, but it could help at some other point or something.

   Report Go to top


« 1 2 3 (4)



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project