Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
89 user(s) are online (72 user(s) are browsing Forums)

Members: 2
Guests: 87

K-L, trixie, more...
Support us!
Recent OS4 Files
OS4Depot.net



« 1 2 (3)


Re: Public screen closing bug in OS4.1
Not too shy to talk
Joined:
2006/12/6 19:36
Posts: 415
@chrisH
@m3x

I can only partially confirm it using SimpleMail and Calculator:

0) Run SimpleMail and change it's config to open on a new SM-screen newly defined in MUI-Database.
1) SAVE, QUIT and re-Run SimpleMail (it opens on SM-Screen)
2) Set Calculator's ToolTypes to open on SimpleMails Public Screen
3) Run Calculator (it opens in SimpleMail's screen)
4) Quit SimpleMail (screen remains opened because of Calculator)
5) Quit Calculator -> screen remains open
6) Running SimpleMail again, and it goes to its correct Screen
7) Quit SimpleMail closes the SM-Screen

But doing the same with a screen defined in ScreenPrefs works properly,
the screen closes when quitting Calculator.

So maybe the bug is in MUI?

AmigaOS 4.1u2 on A1-XE

   Report Go to top

Re: Public screen closing bug in OS4.1
Just can't stay away
Joined:
2006/12/4 23:15
Posts: 1892
@Amigo1

is autoclose option slected in the MUI Screen prefs?

_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top

Re: Public screen closing bug in OS4.1
Home away from home
Joined:
2007/5/19 13:23
From England
Posts: 3490
@broadblues
Auto-Close was NOT ticked in MUI prefs. To be honest I didn't know it even existed (it is easily overlooked), and IMHO auto-close should be the default behaviour.

With Auto-Close ticked, SimpleMail's screen does close correctly when CygnusEd's "visitor window" quits after SimpleMail quits.

I did not test the worse problem (screen unusable) with Ringhio, since that is a separate problem which is supposed to be fixed.

_________________
Author of the PortablE programming language.
I love using Amiga OS4.1
It is pitch black. You are likely to be eaten by a grue...
   Report Go to top

Re: Public screen closing bug in OS4.1
Just can't stay away
Joined:
2006/12/4 23:15
Posts: 1892
Quote:

ChrisH wrote:
@broadblues
Auto-Close was NOT ticked in MUI prefs. To be honest I didn't know it even existed (it is easily overlooked), and IMHO auto-close should be the default behaviour.


I'd not noticed it either. As far as I can tell, testing with the latest MUI, the default now is to have autoclose ticked.
Quote:

With Auto-Close ticked, SimpleMail's screen does close correctly when CygnusEd's "visitor window" quits after SimpleMail quits.


That's cool, problem solved then

_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top

Re: Public screen closing bug in OS4.1
Home away from home
Joined:
2007/5/19 13:23
From England
Posts: 3490
@broadblues Quote:
As far as I can tell, testing with the latest MUI, the default now is to have autoclose ticked.

Great! That means that both of my complaints will be solved by the next OS4 update

_________________
Author of the PortablE programming language.
I love using Amiga OS4.1
It is pitch black. You are likely to be eaten by a grue...
   Report Go to top

Re: Public screen closing bug in OS4.1
Not too shy to talk
Joined:
2006/12/6 19:36
Posts: 415
Quote:

broadblues wrote:
@Amigo1

is autoclose option slected in the MUI Screen prefs?


sorry for the late answer; no, silly me, autoclose was not selected.

   Report Go to top

Re: Public screen closing bug in OS4.1
Not too shy to talk
Joined:
2008/5/2 12:14
From Sweden
Posts: 473
Quote:

xenic wrote:
The whole public screen mechanism and "Screens" created public screens work fine on my system. I don't like Ringhio and don't use it. It opens small notification messages that don't look or act like standard Amiga Windows. They are just small colored blocks with text that appear on the screen background. I think the Ringio notifications look like they belong in some other OS. There are clearly defined mechanisms for visitor windows and requesters on public screens but Ringhio messages don't act like normal windows or requesters and don't appear to be well integrated into Intuition. The problem is with Ringhio and not Intuition or Screens preferences and I think that patching CloseScreen() is a misguided attempt to compensate for a Ringhio problem. Without Ringhio, my public screens (whether program created or Screen prefs created) all work as they should. I think Ringhio should use system compliant requesters instead of the current method.


The OS has to evolve and new things has to be added. Having Ringhio open some old stubborn requester taking focus and require action would just be hacky. We can't be stuck in 1985 forever "just because".

The fact that ringhio happen to look like something on some other OS is just a confirmation that this might be the best and neatest way of doing it.

I have also problems with screens not closing if I happen to close the app just when ringhio pops up something. For me I have a problem with PicShow. If I hit escape just after ringhio has opened it will get stuck. Very annoying.

_________________
Software developer for Amiga OS3 and OS4.
Develops for OnyxSoft and the Amiga using E and C and occasionally C++
   Report Go to top

Re: Public screen closing bug in OS4.1 (FIXED)
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3173
This bug still appears to be present in Update 3. Having just removed BetterCloseScreen from user-startup, I've had to reinstate it as Ringhio notifications are still causing closing screens to get "stuck".

   Report Go to top

Re: Public screen closing bug in OS4.1 (FIXED)
Just can't stay away
Joined:
2007/2/23 13:49
From Finland, the land of Santa, sauna, sisu and salmiakki
Posts: 1061
@Chris
No problems here.

_________________
Rock lobster bit me, so excuse me.
X1000 + AmigaOS 4.1 FE. Be authentic.
"Anyone can build a fast CPU. The trick is to build a fast system." - Seymour Cray
   Report Go to top

Re: Public screen closing bug in OS4.1 (FIXED)
Just popping in
Joined:
2009/3/16 11:27
Posts: 140
Quote:
This bug still appears to be present in Update 3. Having just removed BetterCloseScreen from user-startup, I've had to reinstate it as Ringhio notifications are still causing closing screens to get "stuck".


That comes in my mind right after installation of Update3 and find then your answer. I will leave BetterCloseScreen then in WBStartup.

   Report Go to top


« 1 2 (3)



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project