Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
70 user(s) are online (57 user(s) are browsing Forums)

Members: 0
Guests: 70

more...
Support us!
Recent OS4 Files
OS4Depot.net





Problems executing Loonix scripts
Quite a regular
Joined:
2006/12/2 0:35
From Sydney
Posts: 653
I have a problem executing Loonix scripts under some conditions.

I am trying to configure GMP in its own drawer. I can configure Kaffe in its drawer, so the problem is not universal.

What happens is that when the script tries to run another instance of 'sh' to run a sub-script, the sub-script can not be found. If I try to run that sub-script from the command line, it also says it can not be found.

eg:

/Java/GMP/gmp-4.2.1> ./configure --build=ppc-amigaos
configure: creating cache /dev/null
configure: error: cannot run /bin/sh ./config.sub

/Java/GMP/gmp-4.2.1> ./config.sub
"config.sub" not found

The permission bits for the files are:

/Java/GMP/gmp-4.2.1> ls -l config*.*
-rwxrwxr-x 1 root wheel 23065 2006-05-05 02:36 config.guess
-rw-rw-r-- 1 root wheel 15353 2006-05-05 02:50 config.in
-rw------- 1 root wheel 4437 2007-01-14 20:44 config.log
-rwxrwxr-x 1 root wheel 4127 2006-05-05 02:37 config.sub
-rw------- 1 root wheel 1966 2007-01-07 15:41 config.sub.info
-rwxrwxr-x 1 root wheel 43636 2006-03-15 01:57 configfsf.guess
-rwxrwxr-x 1 root wheel 31164 2006-03-15 01:57 configfsf.sub
-rw-rw-r-- 1 root wheel 111778 2006-04-30 09:31 configure.in
-rwxrwxr-x 1 root wheel 1073487 2007-01-14 19:20 configure.old

Since this process runs quite well in another directory using other scripts, I suspect it is something to do with the permission bits or sh's treatment of them.

Stack is 5 MB.

Any ideas?

   Report Go to top

Re: Problems executing Loonix scripts
Just popping in
Joined:
2006/11/16 20:53
From Denmark
Posts: 74
@tonyw

Just in case that there could be a bug within config.sub (you should always use the newest config.sub/config.guess if possible)... the newest config.sub ... the newest config.guess

_________________
Best regards,
hnl_dk - Henning Nielsen Lund [Denmark]
   Report Go to top

Re: Problems executing Loonix scripts
Just popping in
Joined:
2006/11/16 20:53
From Denmark
Posts: 74
@tonyw

and one extra thing... what version of 'sh' (abc-shell) and coreutils do you use?

_________________
Best regards,
hnl_dk - Henning Nielsen Lund [Denmark]
   Report Go to top

Re: Problems executing Loonix scripts
Quite a regular
Joined:
2006/12/2 0:35
From Sydney
Posts: 653
@hnl_dk

I'm using sh 52.1 (2007-01-07), coreutils 6.7.2 (2007-01-04).

I'll try those later versions, but if abc-shell "can't find" the file under its nose, it can't be a bug in the file contents.

   Report Go to top

Re: Problems executing Loonix scripts
Just popping in
Joined:
2006/11/16 20:53
From Denmark
Posts: 74
@tonyw

Quote:

tonyw wrote:
@hnl_dk

I'm using sh 52.1 (2007-01-07), coreutils 6.7.2 (2007-01-04).

I'll try those later versions, but if abc-shell "can't find" the file under its nose, it can't be a bug in the file contents.


It could be a problem with coreutils (if it is still not working with the new files, please try with the older version of coreutils - I have not got much response about the testversion of coreutils)

_________________
Best regards,
hnl_dk - Henning Nielsen Lund [Denmark]
   Report Go to top

Re: Problems executing Loonix scripts
Quite a regular
Joined:
2006/12/2 0:35
From Sydney
Posts: 653
@hnl_dk

Tried the version of coreutils from 2006-10-29, but no better.

The newer "config.sub" doesn't get very far. It claims that gcc doesn't work and fails. Still trying to find out why.

[edit] Silly me, it IS working now with the newer config.sub and config.guess. It's now failing later in the configure script, so I think that solves the current problem.

Thanks for your help.

[I hate Loonix]

[/edit]

   Report Go to top





[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project