Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
63 user(s) are online (48 user(s) are browsing Forums)

Members: 0
Guests: 63

more...
Support us!
Recent OS4 Files
OS4Depot.net





IBrowse Network crashes
Quite a regular
Joined:
2006/11/24 13:43
From Long Riston, East Yorkshire.
Posts: 756
I am using the OEM version of IBrowse, and seem to constantly get an IBrowse network crash.

When I look at the GR window there is no 'Ignore DSI' option, but after selecting the 'continue program', I get another GR and after selecting the 'continue program' a second time the GR disappears, and IBrowse continues. Until the next time.

Sometimes I don't get the problem at all, but then I get several times in a session.

It is always at the same address 0x014105A4.

This is the beginning of the crashlog:-

Quote:
Crash log for task "IBrowseNetwork"
Generated by GrimReaper 52.1
Crash occured in module kernel at address 0x014105A4
Type of crash: program exception

Register dump:
GPR (General Purpose Registers):
0: 0143EC20 6C2F6B20 FEFEFEFE 00000000 00000000 0000000C 00000010 80808080
8: 01C61C48 01CA2346 00000000 01CA2347 55F53E93 FEFEFEFE 6C38F450 FFFFFFFF
16: 01E40000 6C0028F0 6C38F38A 6C2F6B70 01E41EA0 00000000 01DA3B4A 00000000
24: 00000001 6C2F6CD8 7FFFFFFF 80000014 6B197740 80000016 6FF90000 6C2F6BA2


FPR (Floating Point Registers, NaN = Not a Number):
0: NaN Inf 0.45455 NaN
4: NaN NaN NaN NaN
8: NaN 1.67772e+07 10 0
12: 90 NaN 3.3515e-289 9.30164e+282
16: 8.87614e+306 2.78682e-309 2.75113e+143 4.58445e+90
20: 1.15816e+62 1.57454e+129 3.94625e+187 5.11884e+133
24: 1e+61 1e-59 0.5 4.5036e+15
28: NaN 65536 1.67772e+07 0

FPSCR (Floating Point Status and Control Register): 0x82024000


SPRs (Special Purpose Registers):
Machine State (msr) : 0x0002F030
Condition (cr) : 0x55F53E93
Instruction Pointer (ip) : 0x014105A4
Xtended Exception (xer) : 0xE000FE7E
Count (ctr) : 0x01427A1C
Link (lr) : 0x014225FC
DSI Status (dsisr) : 0x40000000
Data Address (dar) : 0x00000004



680x0 emulated registers:
DATA: 6B6DFFA0 6B6DFFA0 00000000 00000000 00000000 00000000 00000000 00000000
ADDR: 6C2F6D30 6FDAB5E8 6C2F6D50 00000000 00000000 00000000 6FF8F1AC 6C2F6B64
FPU0: 0 0 0 0
FPU4: 0 0 0 0



Symbol info:
Instruction pointer 0x014105A4 belongs to module "kernel" (HUNK/Kickstart)

Stack trace:
native kernel module kernel+0x000105a4
native kernel module kernel+0x0003ec20
native kernel module kernel+0x0004c2ac


PPC disassembly:
0141059c: 44000002 sc
014105a0: 4e800020 blr
*014105a4: 7fe00008 trap
014105a8: 4e800020 blr
014105ac: 7c5343a6 mtsprg 3,r2

System information:

CPU
Model: IBM PowerPC 750 FX V2.2
CPU speed: 800 MHz
FSB speed: 133 MHz
Extensions: performancemonitor

Machine
Machine name: AmigaOne
Memory: 524288 KB
Extensions: bus.pci bus.agp


I wonder if anyone else has this problem?
Or whether someone has a soloution?

Thanks for any help.

   Report Go to top

Re: IBrowse Network crashes
Just popping in
Joined:
2006/12/1 15:25
From UK
Posts: 26
@Swoop

As always:

1) Does it happen with the default IBrowse prefs and default MUI prefs ?

2) Boot without Petunia and obtain a stack trace without JIT so that we can be 100% sure the offsets are valid.

3) Enable the 68k Stack trace for Grim Reaper, otherwise the trace is useless for 68K apps anyway Details are in a document somewhere - either kernel or grim reaper. I can't remember what the variable is called off the top of my head.

If you can reproduce it without JIT, using the default prefs (to eliminate a settings issue), then we might be able to draw some conclusions

   Report Go to top

Re: IBrowse Network crashes
Just popping in
Joined:
2006/12/1 12:06
Posts: 23
@Vader

Same problem here. Now i have disables Petunia in my kicklayout, but how did i obtain a stack trace? Only if the GrimReaper appears again then?
And how did i enable the 68k stack trace? Nothing found in the documents.

Tomcat

EDIT
could i send you my Crashlogs? Or can i delete them?

   Report Go to top

Re: IBrowse Network crashes
Not too shy to talk
Joined:
2006/11/27 8:32
From California - S.F. Bay area
Posts: 380
Start NotePad & type 256, save this as SYS:Prefs/Env-Archive/REAPER.68KStackTrace, copy the file to ENV: as well.
I also tried removing JIT from kickstart, but still got the GRs on startup. I was told to delete my cache & re-install IB, working so far now with JIT.

_________________
Look, only one leg, count em, one!
X1000/PA6T@1800MHz/2Gb/Radeon 4850

   Report Go to top

Re: IBrowse Network crashes
Just popping in
Joined:
2006/12/1 12:06
Posts: 23
@sundown

Which Processor-Version have you installed?

Tomcat

   Report Go to top

Re: IBrowse Network crashes
Not too shy to talk
Joined:
2006/11/27 8:32
From California - S.F. Bay area
Posts: 380
@Tomcat

I installed the 040 version with the ppc version of the javascript.library. I do get random crashes starting & quitting IB. I just now re-installed my original 256MB memory stick to see if my 512MB memory stick is the problem. The 512MB stick passes memtester, but this is a much better test.

_________________
Look, only one leg, count em, one!
X1000/PA6T@1800MHz/2Gb/Radeon 4850

   Report Go to top

Re: IBrowse Network crashes
Quite a regular
Joined:
2006/12/2 0:35
From Sydney
Posts: 683
@sundown

Memtester is not the be-all and end-all of memory testers. I have here a 512 MB registered DIMM that should work perfectly, and indeed I have run memtester on it for three days without a single error being captured. However, it can't reliably run OS4 for any length of time.

It might be because memtester can only test a limited amount of the memory - that part which is not occupied by the system.

[One Of These Days I'll write a proper memory tester that runs stand-alone (without an OS behind it) and can test the whole contents by moving itself, etc. Last time I did that was back in 197x when solid state memory first came on the market and we didn't trust it (!).]

   Report Go to top

Re: IBrowse Network crashes
Not too shy to talk
Joined:
2006/11/27 8:32
From California - S.F. Bay area
Posts: 380
@tonyw

So far no GRs with the original 256MB memory stick, but it's only the first day. I'd be both happy & sad if my 512MB stick was the problem. If thats the case, we really would need a better memory tester. Just seemed to me that ppl that were having a problem with IB had a G3 750GX with 512M of memory. Going to ba an interesting weekend.

_________________
Look, only one leg, count em, one!
X1000/PA6T@1800MHz/2Gb/Radeon 4850

   Report Go to top

Re: IBrowse Network crashes
Quite a regular
Joined:
2006/11/24 13:43
From Long Riston, East Yorkshire.
Posts: 756
@sundown

Quote:
Just seemed to me that ppl that were having a problem with IB had a G3 750GX with 512M of memory.


Hmm. That's my configuration as well.

edit:- Actually I have just looked and mine is a 750FX

But I agree a better memory tester would be good.


Edited by Swoop on 2007/2/18 11:36:20
   Report Go to top

Re: IBrowse Network crashes
Just popping in
Joined:
2006/12/1 12:06
Posts: 23
IBrowse2.4 (020) seems to run better without Petunia.
New problem:
Booting fails on first boot (black screen), need a hardreset for normal booting.
Could all this occur with defective RAM?

Tomcat

EDIT
AOne XE G4/800 512MB RAM

   Report Go to top

Re: IBrowse Network crashes
Not too shy to talk
Joined:
2006/11/27 8:32
From California - S.F. Bay area
Posts: 380
@Tomcat

Don't think ram would cause that, but a weak cell battery sure would. If the battery voltage falls below 2.95V you'll start to have problems like that. If you pull the battery for replacement, leave it out for 10 min to re-set uboot. Before pulling the battery, open a shell & type nvgetvar >prt: to get a hard copy on paper & then I open uboot prefs & there's a menu option to save your setting to a file on disk that can be re-loaded back & saved as the h/w configuration setting will be lost.

I haven't had an IB startup crash since going back to the original 256MB mem stick, but I still get the odd recoverable alert when quitting.

_________________
Look, only one leg, count em, one!
X1000/PA6T@1800MHz/2Gb/Radeon 4850

   Report Go to top

Re: IBrowse Network crashes
Just popping in
Joined:
2006/12/1 12:06
Posts: 23
So, new battery, other RAM, now checking a few days.
Old battery had 2,2V... could that destroy/trashing some variables in NVRAM?

Tomcat

   Report Go to top

Re: IBrowse Network crashes
Not too shy to talk
Joined:
2006/11/27 8:32
From California - S.F. Bay area
Posts: 380
@Tomcat

2.2V would defininitely give you a black screen. Custom uboot settings may need to be set again like DMA & h/w config variables. If you used uboot prefs to save your settings first, you would just load the file back & save.

_________________
Look, only one leg, count em, one!
X1000/PA6T@1800MHz/2Gb/Radeon 4850

   Report Go to top

Re: IBrowse Network crashes
Just popping in
Joined:
2006/12/1 12:06
Posts: 23
OK, RAM broken. Other 512MB-RAM runs perfectly, but only borrowed.
Which RAMs are working, 512MB or better 1024MB? The list on intuitionbase is too old, i'm afraid.

Tomcat

   Report Go to top

Re: IBrowse Network crashes
Not too shy to talk
Joined:
2006/11/27 8:32
From California - S.F. Bay area
Posts: 380
@All

Well after replacing my 512Mb mem stick with the original 256 that came with my micro, IB still gives me GR'ers on start & quitting.

One other thing that I wonder about is I have 2 keys, 1 for v1.x & another for v2.x. Both are required to unlock IB & I'm wondering if that can cause problems with v2.4.

_________________
Look, only one leg, count em, one!
X1000/PA6T@1800MHz/2Gb/Radeon 4850

   Report Go to top





[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project