Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
92 user(s) are online (74 user(s) are browsing Forums)

Members: 1
Guests: 91

K-L, more...
Support us!
Recent OS4 Files
OS4Depot.net



(1) 2 »


Crashes with OS4 Final
Quite a regular
Joined:
2006/12/2 0:35
From Sydney
Posts: 654
I get occasional crashes when trying to open IB 2.4 under OS4 Final. The crashes are always exactly the same place and DSI.

Would you like a crash log? Here or privately?

   Report Go to top

Re: Crashes with OS4 Final
Not too shy to talk
Joined:
2006/11/27 18:02
From Somerset, UK
Posts: 353
@tonyw

Likewise.

Serverin is a IBrowse Guru maybe he can comment if it is a known problem and if it will be patched ?

I tried changing codecs to 040 but that made no difference either.

Crashlogs available too.

I've had a bit of success by reducing the amount of ram available for the jpeg decoder and reducing the amount of connections to 4. But as you say the occassion crashes are still there.

Also having no default homepage helps with the startup too here.

_________________
A1XE, A1200T, X1000 & X5000
   Report Go to top

Re: Crashes with OS4 Final
Just popping in
Joined:
2006/12/1 15:25
From UK
Posts: 26
@Jurassicc

IF and only IF these are 100% reproducable using the default IBrowse config, the default MUI config, and with Petunia disabled (ie. booting without Petunia, not black listing IB), then yes, please e-mail me the crash logs.

The reason for saying that is, the first two give us a level playing field for reproduction. The latter is because Petunia can screw up the offsets and we spend ages chasing things that aren't there, plus it will indicate if there may be a bug in Petunia.

You can get my e-mail from various sources, but if you can't find it, send me a PM

Best Regards,
Dave Fisher

   Report Go to top

Re: Crashes with OS4 Final
Quite a regular
Joined:
2006/12/2 0:35
From Sydney
Posts: 654
@Vader

OK, I'll disable Petunia for a few days and see if it still crashes.

How "default" do you mean"? I'm running IB on its own MUI public screen, but otherwise as it was in the box. Is that OK?

   Report Go to top

Re: Crashes with OS4 Final
Just popping in
Joined:
2006/11/26 11:55
From South Wales, UK
Posts: 206
@tonyw

Ive had a similar experience,
Majority of the time all is fine but once in the while I get a DSI when starting, and that is running IBrowse first as soon as I have booted.

   Report Go to top

Re: Crashes with OS4 Final
Amigans Defender
Joined:
2006/11/18 10:33
From Flinders NSW Australia
Posts: 772
@tonyw

gday tony im running Ib2.4 on final without issues no gr yet
have you a later update than us could be somthing in that doing it :)

_________________
Amiga is the heart and soul of computing nothing else comes close
   Report Go to top

Re: Crashes with OS4 Final
Just can't stay away
Joined:
2006/11/26 16:47
Posts: 1420
68k mui libs?

   Report Go to top

Re: Crashes with OS4 Final
Quite a regular
Joined:
2006/12/2 0:35
From Sydney
Posts: 654
@spotUP

Quite possible. All the libs that you have to fetch and install are PPC, but many supplied with MUI are still 68K.

The DSI I get on starting is always from address 0x4E8. It would seem that "it" is writing to 0x4E8(something), while "something" is null (r8 in the dump).

On the other hand, the emulated 68K code shows nothing remotely like 0x4E8. Maybe the offset is something internal to Petunia.

Anyway, I'll run without Petunia (yawn) for a few days and see if I get any similar crashes.

   Report Go to top

Re: Crashes with OS4 Final
Just popping in
Joined:
2006/11/16 20:53
From Denmark
Posts: 74
@tonyw

Hi Tony

Check this thread (and update all things that I link to):
http://amigans.net/modules/newbb/view ... ost_id=5682#forumpost5682

_________________
Best regards,
hnl_dk - Henning Nielsen Lund [Denmark]
   Report Go to top

Re: Crashes with OS4 Final
Quite a regular
Joined:
2006/12/2 0:35
From Sydney
Posts: 654
@hnl_dk

Hi Henning,

I had all of those already, but BetterString was new, so I'll install that and see what happens. Not going to install "The Bar" until I know more about it.

Grr, this is as bad as Loonix - having to chase all over the world to find the "latest versions" created by unknown people, without any authority behind them. Who knows what they do or how they behave under OS4?

   Report Go to top

Re: Crashes with OS4 Final
Just popping in
Joined:
2006/11/16 20:53
From Denmark
Posts: 74
@tonyw

Hi Tony

Problem is that if you have installed the full version of IBrowse, does it overwrite your MUI classes (the classes mentioned in the other thread) with 68k versions that do not work correctly on OS4 (at least it looks like it, as the applications that use it will crash if you don't replace them with the native versions).

_________________
Best regards,
hnl_dk - Henning Nielsen Lund [Denmark]
   Report Go to top

Re: Crashes with OS4 Final
Just popping in
Joined:
2006/12/1 15:25
From UK
Posts: 26
@tonyw

Quote:
How "default" do you mean"? I'm running IB on its own MUI public screen, but otherwise as it was in the box. Is that OK?


Fully default

Backup and rename the prefs file (ibrowse.prefs) in the IBrowse directory to something else, so that IBrowse uses its factory defaults.

Go into Envarc:MUI/ and backup and rename any ibrowse prefs located in there, and backup and rename <global>.prefs so that MUI is fully back to its own factory defaults.

Reboot and use IBrowse until it crashes again. If there are no further crashes, reinstate the <global>.prefs and use that for a while. If there are still no further crashes, reinstate any IBrowse MUI prefs. If there are still no further crashes or if you dont have any IBrowse specific MUI settings, then reinstate the ibrowse.prefs.

If at any point the crashes come back, its likely to be one of your settings, so then we have to work out which so we can see if its IB or MUI.

It may sound like a lot of work, but during beta testing (of 2.3 iirc) we had one crash bug which took forever to track down and in the end it was a bug in NewString (no suprise there!) which was only triggered when the cursor was set to flashing and the time delay was set to a certain value.

If the crashes are full reproducable with a clean default settings for MUI and IB, then we can simply reset to defaults to try and reproduce it. If its triggered by a setting and our settings are different to yours, then its a nightmare to track down.

   Report Go to top

Re: Crashes with OS4 Final
Just popping in
Joined:
2006/12/23 18:30
From UK
Posts: 63
@hnl_dk

Quote:
Problem is that if you have installed the full version of IBrowse, does it overwrite your MUI classes (the classes mentioned in the other thread) with 68k versions that do not work correctly on OS4 (at least it looks like it, as the applications that use it will crash if you don't replace them with the native versions).

Strictly speaking, that's not the case. True the installer only has 68k NList classes, but these will only overwrite any PPC ones if your PPC ones are older than the ones supplied with IBrowse. Given that NList was updated a couple of days before IBrowse was released, it's understandable that probably most people had old NList classes. The latest versions can be found at http://sourceforge.net/projects/nlist-classes/ (as linked to on the IBrowse website, and mentioned during installation). Obviously, the pre-installed OEM version was supplied with OS4 native NList classes.

   Report Go to top

Re: Crashes with OS4 Final
Quite a regular
Joined:
2006/11/25 13:38
From Adelaide South Australia
Posts: 606
@Vader

This is exactly what I did and IBrowse works great.

ace

   Report Go to top

Re: Crashes with OS4 Final
Just popping in
Joined:
2006/11/16 20:53
From Denmark
Posts: 74
@Futaura

Hello Oliver

Thanks for telling.

_________________
Best regards,
hnl_dk - Henning Nielsen Lund [Denmark]
   Report Go to top

Re: Crashes with OS4 Final
Quite a regular
Joined:
2006/12/2 0:35
From Sydney
Posts: 654
Well, I disabled Petunia altogether (commented out the line in Kicklayout) and after a week I had no IBrowse failures at all.

Within days of re-enabling Petunia, I get the same 0x4e8 crash again on starting (about once in five starts).

I'll try the prefs suggestions.

   Report Go to top

Re: Crashes with OS4 Final
Just popping in
Joined:
2006/11/29 12:49
Posts: 55
@tonyw

What "0x4e8 crash"? Where is that number coming from? Can you reproduce somehow the crash? It might indicate a Petunia bug.

   Report Go to top

Re: Crashes with OS4 Final
Just popping in
Joined:
2007/1/1 12:01
From Latina, Italy
Posts: 208
@Vader

thanks for the info, i disabled Petunia on my system in kicklayout and now i have a very stable system !!!!! Ibrowse not has random crash, seems that petunia has some bugs ??

   Report Go to top

Re: Crashes with OS4 Final
Just popping in
Joined:
2007/1/1 12:01
From Latina, Italy
Posts: 208
@tonyw

"The latter is because Petunia can screw up the offsets and we spend ages chasing things that aren't there, plus it will indicate if there may be a bug in Petunia."

i think this is really!

   Report Go to top

Re: Crashes with OS4 Final
Quite a regular
Joined:
2006/12/2 0:35
From Sydney
Posts: 654
@rachy

The "0x4E8" is the DAR (every time). It is not always reproducable (only happens about once in five starts), but the crash is identical each time. It MIGHT be the first time that Petunia is used - YAM is the only other 68K app that I use soon after booting. I can send you a log if you would like, I have one saved here.

After the crash, the process can not be continued (without crashing again) and I have to reboot since resources are locked, so it is really annoying.

BTW, I never had this problem with IB 2.3, this crash is new to IB 2.4 (which doesn't mean that it's a bug in IB or Petunia, could easily be something else).

   Report Go to top


(1) 2 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project